Problem with version 2.02.32 not playing back most mp4 files

I am mostly using this box in my RV as a media player for my MP4 movies. It all worked great, until i decided to do the update to version 2.02.32. Only a fraction of my MP4 files were playing, so I decided to roll back to 2.01.86 and it is all working again. Something definitly got busted on the update. I tried to compare some of the very few files that were playing with those that did’t, but could spot no obvious issues other that the file that were playing had a little lower bit rate…


Welcome to the Community.

Maybe you should try contacting WD’s Technical Support about this. You can do so either by phone or email.

To Contact WD for Technical Support

Support by Country

Sorry, but I am not going to contact tech support. That is fixing a problem with an error. I reported the problem here and hopeflly, they read this and take some inititiative themselves!

Update to the latest firmware released today, it fixes the issue.

Have they released an update for the Live Streaming ?

The only update i can see is 1.02.17 for the WDTV Media Player (2014)

(which i have, and have updated and so far so good for mp4’s)


I have the WD TV Live streaming media player the latest version for that one is 2.02.32. and it as playback issues with MP4’s…Does anybody know if I can load the firmware from the WD Live media player?

i have asked someone privately to test it  (not gonna explain *how to do it*)

[they have a spare smp … for testing]

it “could” do 1 of 3 things …

  1. Work

  2. Nothing

  3. Brick your device

Wait until …

  1. The person i contacted replies with what happened


  1. An “Official Firmware” Update for the SMP  (whenever that will be)

In the mean-time … continue to use 2.01.86 (which you rolled backed to … according to your 1st post which plays MP4’s fine)

1 Like

@ JoeySmyth thanks for the help. I am going to wait until i hear from somebody that tried it…