Problem with Users: can't create a user have read only access

 tl;dr: I want to have a shared folder with read-only permission for anyone in the net.

Ok, I have no idea what am I missing.

Just bought the MyCloud 2TB, fw v03.04.01-230 (not going to upgrade for now).

I’ve made the first user and I can login into the dashboard (webpage), no problem.

The first problem comes when I create a new user, I can’t use these credentials to login in the webpage and configure things.

Is this normal?

Only the first user is able to access the dashboard?

I first tried creating users with no password, then with password but no luck, only the first created user is able to enter the dashboard.

Second thing, I want to create a shared folder with read-only permissions and viewable by anyone in the net.


I tried making a user with no password and a user with password, but in Windows I can’t acces the shared folder unless it’s configured as ‘Public’.

Am I doing something wrong?

I haven’t been able to find solution anywhere yet.

PS: should I just ditch this OS and go with OpenMediaVault instead?

Hello, welcome to the WD Community. Only the admin user (the first user you created) has access to the dashboard to change and manage the configuration of the unit.

When you create a read-only share, you need to give permission to the users that you want to have access. Does the first user you created have access to this share?

Ok, so only the administrator can access the dashboard, that’s the normal way I guess.

(Maybe if I create more administrator users using ssh, maybe later)

About shares, I create one “testing”, then give full acces to one user, read-only to another, and none to another.

I’m using Windows Explorer to access the shared folders (I find them under the ‘network’ icon), when I select a Public folder I can see and red/write. But when I try to access a folder which is not public (requiring a password) then I get an error and can’t acces it.

The Error : ""xxxx folder is not accessible. You may not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions.

Multiple connections to a server or shared resource by the same user, using more than one user name, are not allowed. Disconnect previous connections to the server or shared resources and try again."

Don’t really understand this message.

Hi, It seems that you are connected to the drive unsing a different user. Try to disconnect all the mapped shares and rebooting the computer and try to access the shares then. Please take a look at this  link for more information.

Connecting using the ip works.


I’ll try to make an alias for the share and see what happens.