Problem with the installation of the WD SSD monitoring Windows 10


#1

Installed a clean Windows 10 x64.
Downloaded from site WD SSD Dashboard, unpacked the archive and start WDSSDDashboardSetup.exe
Returns this window


#2

Hi,

Are you log in as the admin on the PC? or running the installation file as the administrator?


#3

The account with the rights of the administrator, the application was started right to start on behalf of the administrator


#4

the installation process on video


#5

Similar problem. In Windows 10 x64. The program is not installed and shows same message. Tech support does not respond and ignores my appeals. Warranty to pass this SSD not only because of problems with the software. I am disappointed and never suggest to buy products from this company because of their attitude towards customers.
I tried to put version 1.4.4.5 as advised in this community. Barely found this version on the Internet. The problem is the same. Software does not install with an error. Products raw!


#6

here is a link to get the old wd dashboard v1 works fine with win 10 https://1drv.ms/u/s!An8E1TjppR7igZt2Xg9ldMjerQB6Mw


Dashboard 2.0.1.0 - WD SSD not detected - Possible Bug - Version 1.1.4.5 finds drive
#7

Dear Tim,
Thank you very much!

Best regards, Dmitry


#8

you are welcome tell everyone about it


#9

Tim, thank you! This version installed fine :slight_smile:


#10

your welcome


#11

My version 1.4.4.5 isn’t put too. Mistake.
Translation of An English “Installation error. Repeat attempt later”.
Not flood plain in what there can be a problem?


#12

So I backed up another laptop onto the My Passport Ultra only a few days ago, and it was also Windows 10 and everything, and the passport shows the backed up data there, but for whatever reason I cannot access or download those files. I can see them but I cannot do anything more than that. And when I try to go into the WD Backup, it does not show any device to backup or restore to, even though the passport is connected to the computer through USB. Am I not using it correctly or is the drive messed up?


#13

Hi Gang, 1st Post here. Clean install Windows 10 Pro latest creators edition. Initialized my WD Black PCIe NVMe M.2x4 SSD as GPT and installed Windows from USB stick in under 15 min. The latest version of the WD Dashboard SSD Monitor software was un compressed and then right clicked and run as Administrator and installed and working no problems.

Very pleased with the drive, though it does run a little warm at 58 deg C but what the heck, it is designed to do that.


#14

Same problem, SSD Dashboard did not recognise my new WB Blue 250G, after initialising and formatting. The above link to Dashboard 1.1.4.5 worked straight up. WD needs to do some work on the latest 2.0.1 version


#15

Yep, version 1.4.4.5 does find my drive. version 2 does not.

Windows 10 x64


#16

Nice to know that nothing has changed looks like no support for this issue


#17

Mine installed fine after about the second or third Cumulative update to Windows 10 Pro Creators edition, did a clean install after upgraded to it a few weeks after the cumulative updates started coming out. Installed my usual software, tried Western Digital SSD dashboard 2.0.1.0 and installed and works fine now. Perhaps Compatability issue with Windows at first was the cause of this issue