Problem with SSD drive still under warranty


#1

My blue SSD drive and shortcuts to programs suddenly no longer appeared on my desktop PC , I checked in bios and it’s not there either. I tried different cables etc but the drive appears dead,
I loaded up WD support page and checked the warranty status, it accepted the serial number, gave me details of the drive and that the warranty expires May 2020 and pointed out that I had to first register the drive.

Registering the drive worked fine and the drive is now registered to me.

However, when trying to create an RMA it refuses to recognise the serial number, I open the ‘contact us’ page where I have to give details of the problem but it involves putting in the serial number which it won’t recognise!

I checked over & over it is exactly the same as typed in before so now I am stumped as to how to proceed

I know this board is probably not the right one for problems trying to contact support but I can see no other way, particularly as I’m rather deaf and would have to get someone to phone up for me.

EDIT: problem now sorted