Problem with some units in iPhone

Hello
I have a MyCloudMirrow Nas. Has now reformatted it and created some devices. On my iPhone7+, I have the My Cloud app and that is where I have problems with some devices. When I try to open a folder on ex. “Public” I receive the following message:
“The Internet is unavailable. Please try again later.”
On my other devices, I have no problems and all settings are identical. Have tried restarting the server, and deleted the app on the iPhone and installed a new one.
Someone who has an idea for solution.

/ Lars

You likely have lost Cloud Access in the My Cloud. Here is a solution for regaining cloud access.

There is a most common problem of iPhone that is the battery problem and I am suffering very badly from this issue. I tried hard for resolving the issue on Hotmail Support but found no such permanent solution. I need some suggestion to fix this problem.

I had never get such trouble in my Iphone 6 plus it’s really work faster than other if you face any issue in synchronizing setting in windows 10 operating system then just visit here to sync settings windows 10 operating system with the help of our tutorial and do it online in easiest way.

yes problem with some units in iphon i use iphone 7 my mobile problem is not up to date iTunes. Get Fix Satta Matka Game.

There is a lots of problem regarding the Vonage login
and insuranceservicenow

I used to have the same problem with my I phone 6 and battery start heated when I switched it to charge with Titan gel