Problem with new BPVT Laptop drive and Vista

I am hoping someone can give me a suggestion.  A nearly new (except for 1 month as a data drive) WD 640 Gig laptop drive (WD640BPVT) is driving me crazy because I cannot get it to load a re-install of Vista SP1 on a 2 year old Acer laptop.  The drive passes all tests with WD and also Acrosis and HD Tune.  SMART parameters are all 100% and WD Lifeguard Diagnostics all show “Pass”.   I have not RMAing the drive because it passes its tests. 

I am familiar with MS OS’s since Dos 5 and have no problems in the past changing drives, upgrading OS’s, resizing partitions, fighting viruses but his has me pulling my hair.  Now is a personal challenge!!

My Frustration

I want to install a new WD640BPVT advanced format HD in my Acrer 8930G laptop. 

The problem is after I have reinstalled the Acer Vista OS from the Acer Back Up DVDs and after it asks for a re-start.  I will; restart the Acer and it starts to install and configure and then the laptop stops and I get the message “Windows setup could not configure Windows to run on this computers hardware”. 

The Acer is unmodified and I am running the Acer factory Operating System which is Vista SP1.  The laptop and the OS is not moded, hacked or changed from when it was purchased.  I formatted the new drive.

To solve this I have:

Run virus scan, ran WD Lifeguard Diagnostics, ran WD Align again and it shows the drive as correctly aligned, I made a new set of install discs and verified them and tried to install from them, I Googled the problem, I googled looking for problems with the laptop, i partitioned the  WD640BPVT to 300 G, formatted and tried to re-install, I aligned it again and tried to re-install.  It always runs to the set up stage and then it always gives the same message so I know it is not a bios issue with the 640 gig size.  I think I did the install about 7 times.  I frustration I took an 320 Gig HD out of my external hard drive and put it in the laptop and I did 2 reinstalls and both worked using that hard drive.  I found I could re-install, setup and start successfully from either back up set of DVD’s so I know both sets of install DVD’s are good as is the laptops DVD drive. 

I want to install a larger HD.  I do have the benefit of the fact that the Acer is working fine and I have its 320 Gig HD to put back in it while I resolve this.

What have I missed?  What is wrong?

You will note the laptop is working (it is waiting for a larger hd), I verified the reinstall DVD’s will work by successfully reinstalling the OS to a different hd, its been virus scanned by Avast and AVG.  I ran WD Align because it was used briefly in an XP machine but its been re-formatted about 5 times since then.  I even re-ran WD Align it says the disk is fine. 

Suggestions pleeese?


Even if the drive shows up in the BIOS I suggest you to confirm with Acer if your system supports a 640 GB drive.  I have seen a lot of cases like this, where it ended being a incompatibility with the drive.

Thanks for the suggestion but I do think it is the BOIS. 

Acer has not replied to my inquiry but here is my reseasons:

1 I partitioned the WDC disk to 290Gig, tried to install and got the same error.  The factory disk was 320 Gig.

2 My model of Acer was available with up to a 500 Gig HD depending on the model number (basically which retailer it was going to)

3  The latest BIOS version is April 2010 and I am running that BOIS (it came with the machine).

4 On-line retailers including show up to 1.5 TB as allowable

Any more comments or suggestions would be appreciated.