Problem with "My Book Essential 1T Drive"

I’m having a lot of issues with my “My Book Essential 1T drive”. When I first bought this external hard-drive, it worked great and had 0 issues. However, a couple of months later the drive is acting very strange. Here is a list of the issues I’m experiencing: (I’ve tested this drive on multiple computers and I’ve experienced these issues over and over)

  1. When I plug the drive into my desktop, my OS (windows 7) recognizes that a device has been plug in by playing a sound effect. The hard drive light begins to flicker and the drive seems as though it is stuck in a loop because it makes the same sound over and over again. When I go to My Computer, the drive is NOT present. I then have to unplug the usb device from my computer and recycle power to the hard drive. If I repeat this process, eventually the device will be recognized by the OS. This problem also occurs when I try to plug the hard drive into my Laptop or any other computer. This leads me to believe that it is an issue with the drive and not the computer.

  2. When the drive is detected by my OS, the drive can only be accessed for a short time. After about 5 min. or so the drive locks up and the OS acts as though the device got disconnected. The fact that it works for a short period of time has me somewhat baffled. I would try to switch the USB 3 cable, however the cable that came with the drive is somewhat unique.

To be perfectly honesty, I’m really ticked off about these issues, mainly because I stored some valuable data (i.e. photos, home videos, ect.) on this drive that I cannot reproduce. If anyone out there can help me fix these issues, I would be extremely grateful.

As per your description this drive is faulty or is about to fail, if possible use Photorec or Recuva to retrieve the information and contact WD for replacement.

I have the same problem, except I just bought the hard drive yesterday from Bond and Bond on special, and unpacked it today, plugged  it into the USB port of my Sony Vaio which never had any issues with not recognising devices, and … it’s not working. My laptop indicates that a device has been commected (by a slight clicking sound, same as you) and then nothing. When I first plugged it in it said that the driver was installed and the device is ready for use, but when I go into Explorer, and My Computer the device doesn’t show up. Furthermore, when I click the little icon “Safely Remove Hardware” and go into the properties it says the device is WD blah blah, and is working properly. I don’t know what to do now, the hard drive’s not working and I’ve tried unplugging it and pluggin it back in several times and no success. 

Does anyone know how to make it work?? 

Any advice is greatly appreciated!

try plugging the drive’s power adapter directly into the wall socket.  it might not be getting enough power.