Problem with Media Servers when using Powerline Adaptor

Hi Folks,

I’m having a problem seeing Media Servers across my wired network which is using WD Powerline Adaptors. Below is a pic of my network which will hopefully help me explain the issue!

So when a device is connected wireless to the network it can see all the Media Servers (WDTVLIVE Hub, QNAP, Sonos & the PC itself) . Likewise, if I plug a wired device (such as another WD Live Player) directly into the router I can again see all the Media Servers. Via the Powerline adaptors its a different story. The only Media Servers a device wired via the powerlines can see is the QNAP (& I’ve worked out this is because its plugged directly into the router) or a Media Server that is connected to the same powerline device. For example, if I plug the WD Live Player to the powerline adaptor in the Family room then it can see the WDTVLIVE Hub & Sonos (as its connected to the same powerline as these 2 media servers) and the QNAP (as the QNAP is connected to the router). If I connect the WD Live Player to the powerline in the Games Room it can only see the PC Media Server and the QNAP.  Finally if I plug the WD Live Player into the powerline in the office then it picks up all Media Servers, I guess because this powerline is plugged directly into the router. What I want to achieve it to see all servers from all devices on the network (and in particular to see the WDTVLIVEHUB in the Family Room from the SmartTV in the bedroom!

Is this acheveable? Am I doing something wrong or is this just a problem with the powerline adaptors? I’ve completely reset everything, but no diffeence. Both the PC and WDTVLIVE Hub are WORKGROUP. I’ve noticed that I can see all devices as Network Shares across the network via the powerline adaptors, just not as Media Servers (and I can’t use Network shares on the smart TV).

Hope someones got some ideas for me!


Here’s a link to the PDF Manual. Page 8 shows these devices being connected to a WDTV Live/Live Plus. So it must be able to be done.


I’m wondering if it might have something to do with Create a Private Network Page 9


1 Like

Nah, no joy with that unfortunately. I had already created the private network when I first installed them but just tried resetting them and re-doing the private network setup, but its still not working

Make sure the powerline adapters are plugging into the LAN (not WAN) side of the routers.  Also note your 2.4 GHz channels are overlapping.  The only 3 channels without bleeding into the other ones are 1, 6, and 11.

Attached is a diagram of how my home network is set up.  I’ve got one internal DHCP server that serves the whole house.  The SSIDs are the same so I can be mobile throughout the whole house.  I keep the same DHCP address and can access all resources on the network.

I had the exact same problem as you and was able to resolve the issue by creating a WD LiveWire private network.  It sounds like you already tried this but thought you might be interested to hear anyway.