Problem with Laptop not shutting down when hooked up to MyBook (Please Help)

So here my problem a very new laptop I have running Windows 7 (64bit) will not shut down when I map the network drive to be seen by it.  I’ve literally let it run for 6+ hours showing the “windows is shutting down”  screen and it just never does.  The computer has been stripped and had just the operating system re-installed and I still have the same problem.  Has anyone run into anything similar?  Any assistance would be very much appreciated!  Thanks in advance.

This has been discussed several times here. Disable the Mionet service on the MBW and Indexing on the computer.

I have exactly the same problem.  Windows 7 64 on Lenovo X201 with MyBook World Edition.

The computer will not go on standby or shutdown as long as it has seen MBWE on the network even for a minute.  Turning off or disconnecting MBWE makes no difference as long as it has been seen by the computer.  USB ports also get messed up.

It first happened as soon as I got the Lenovo something like 6 months ago. Took forever to diagnose. But updating the firmware on the MBWE fixed it at the time.  Everything was fine, but then it started happening again. Don’t know why. There was another firmware update available at the time and by updating it again I again fixed it for a while.

About 2 weeks ago it started happening again. No firmware update is available now, so I can’t do that again. I have contacted WD support. Had a number of exchanges with them. They suggested a few things. Nothing worked. Now I’m supposed to contact Level 2 support.  Basically they don’t have a clue.  I’ve started shopping for another drive.

By the way, there are many posts on this topic. It’s a common problem.

6/17/2011 Spent about an hour with WD Level 2 support and the problem appears fixed.  It is something they know about and have to play with Windows settings to eliminate.

Same Problem with My Toshiba Laptop.  I read most of the posts and had to combine a few together to make my computer  shut down.  Here is what I tried.  This is a wireless connection.

  1. Download the latest Discovery software and install it.  It has the uninstall in the new version.

2. After installing the software go to remove software and uninstall it.  No kidding that is what I had to do.

3. Go to device manager and locate the drive section.  You should see the Mybook World listed.

  1. Disable the drive don’t uninstall the drive.  If you uninstall the drive Windows will reinstall the drive.

5. Shut down the drive.  You may need to use the power button again.

6. Restart the drive and boot the computer.  When you shut down again it should work.

7. Go to computer and then look in network to see if MyBook shows up.  It may take a few seconds to appear.

  1. Make a short cut to the drives if you need to access them quickly.

So far everything works.  My son has Windows XP on his system and he doesn’t have a problem.  It seems Window 7 and the WD drives and software don’t like to work together.  I hope WD will get a fix for this soon.  I use the drive with a WD Player Plus and it works great.  I plan to add another WD Player Plus to my other TV.