Problem with deleting files using WD 2go w/ MBLD


I just set up my new MBLD 4TB and registered WD 2go. I have created a private share and granted my user full access to it.

Then, I used WD 2go, and mapped a network drive on Windows 7 (x64). First, I tried to upload a small file. Although it was much slower than expected (it took several seconds doing “discovering item”), it successfully uploaded the file.

Then, I tried to delete the file. After another few seconds’ “discovering item”, it displayed a progress bar and the item disappeared in the explorer window. But after I did a refresh view (F5), it reappeared!!

I tried several times, and it was really frustrating. It appeared that the file was not really deleted at all, since I can still open it…

Any kind suggestion or advice is welcome!

BTW, is it normal to have such kind of slow response when using WD 2go? I was trying in my home network, with the drive sitting a few inches from me. And it took more than 5 seconds to just list all the files…

Thanks a lot!

Hi, go the the MBL dashboard and check if you enabled read and write permissions for the private folder you are trying to the delete the files from.

Thanks, Alucardx23. I did check, and the user was already given full access…