Problem Using WD 10TB Red NAS HDD with USB 3

#1

WD 10TB Red Internal NAS HDD
Model: WD100EFAX-68LHPN0, Firmware: 83.H0A83

Windows 10 Pro Version 1803

I video (Full HD) and edit numerous lectures for several non-profits. Until WD shut down HGST, I always used HGST Deskstar NAS drives because of their reliability and excellent MTBF. Since laptops and most desktops no longer have eSATA connections, I changed from eSATA connections to USB 3 connections by placing my drives in an USB 3 adapter box using an Addonics ADSAU31R - SATA to USB 3.1 Rack-mount Converter. This worked well.

Since HGST drives are no longer manufactured thanks to WD, I recently purchased WD Red 10TB internal drives. While copying from either an ASUS desktop or ASUS laptop, Windows 10 sometimes waits a long time before it starts copying. At other times, it just locks up and will not copy. This occurs sporadically, but enough to be annoying. It is acting as if the drive is in some low power state, but refuses to turn on when necessary. So I checked the Windows power related settings.

In Power Options, all Windows 10 Pro computers have “Turn off hard disk: 0 (i.e. never)” and “USB selective suspend setting: Disabled”. In Device Manager, Universal Serial Bus Controllers Power Management tab has “Allow the computer to turn off this device: unchecked” for all USB controllers.

All three WD 10TB Red Internal NAS HDD have this sporadic problem. I ran the WD Data Lifeguard Diagnostic on all three drives. They passed.

I have tried different USB 3 adapter boxes, and USB 3 cables.

In contrast, none of my HGST 4, 6, and 8 TB Deskstar NAS have this problem.

In speaking with WD Technical Support, he said that the WD Red drives don’t work with USB 3, but could not explain why. This seems strange since the HGST Deskstar NAS have no problems with USB 3. Why should WD Red drives not like USB 3?

Is anyone having the same problem?
Is there a work around?
Is there an alternative NAS drive that works with USB 3.
Note: Most non-NAS drives have poor MTBF. I cannot risk having corrupted data.
Does the WD Ultrastar work with USB 3?

Thanks in advance for any feedback.