Problem updating Theme via web interface

Hey,

I’ve changed themes probably a hundred times on my SMP in the last 12 months and never came across this problem before.  I installed AlaskaDark v1.2 a few weeks back and today when I uploaded a new theme to the SMP it did nothing with it.  

I’m using Chrome (as usual) and the theme zip file is only 16 MB (so size is not the issue).  I was attempting to load the Kudos theme but after I had issues I tried several other themes and none of them would work either.

The issue is that I can access the web interface, upload the theme file and then I get the “updating…please wait” message and that’s it.  I have no issues accessing the attached drive over the network and I’ve tried from several PCs.

I’ve done a factory reset and still I can’t load a new theme.  I can select and load the default Mochi theme Ok and then switch back to the AlaskaDark theme.  I thought the factory reset would’ve deleted the second theme file but it didn’t.

From what I can tell, the theme uploads to the SMP but it does nothing with it.

Any ideas?  I’ve tried using IE but I get the exact same issue.

Oh, I’m still back on Fw 1.09.10.

Cheers

Sorry to hear you’re having problems :cry:

If i could help, i certainly would … but i don’t own an SMP

I would only be guessing …

ie.

* did you try the ‘reset hole’ with a paperclip ?

* apply the default Mochi Theme then try uploading another theme ?

* try Firefox Browser

* you could out of desparation update firmware … as that should clear everything (but,possibly another set problems)

Not be be alarmist, but flash or nand memory has a finite number of write/erase cycles … so i wouldnt go changing themes 100’s of times.

http://en.wikipedia.org/wiki/Flash_memory

I’m not saying that’s the problem, but i would keep it in mind and curb your usage of the feature.

2 Likes

From your link.

Memory wear

Another limitation is that flash memory has a finite number of program-erase cycles (typically written as P/E cycles). Most commercially available flash products are guaranteed to withstand around 100,000 P/E cycles, before the wear begins to deteriorate the integrity of the storage.

With 100 themes a year the posters player should only last another 1000 years!

1 Like

Yeah, and my Panasonic Plasma panel is gonna last the 35 Years as quoted by the manufacturer

this happend to me one time to took me some time to figure it it out I think i had uploaded to many themes switch to mochi turn off smp keep holding power button until it turns off let it boot back up and then go and delete the ekstra theme 

option/delete theme and then you can upload a new one

Bugger.  looking more and more like a flash memory problem.

As per Joey’s post, I tried a reset using the button on the underside of the box and set the default Mochi theme and then uploaded a new theme file using firefox.  No dice.

I then tried ztrust’s suggestion of deleting the extra theme.  This worked but the same problem persisted.  I even tried using one of the online themes that are available from WD.  It appears to download Ok but then fails with a “unable to load theme message”.  

Now I’m stuck with the default theme.

I’m tempted to try updating the firmware but as Joey says this could cause issues, partucularly if the flash was to bugger up.

I’m outta ideas.  Anyone else have anything?

Oh, my statement about having updated the theme a hundred times in the last 12 months was a bit of exaggeration for emphasis to highlight i wasn’t a noob.  However it would certainly be in the 50 to 100 range as I was testing my own theme files at various stages.  I would hate to think that would be enough to ‘wear out’ the nand memory.

Cheers

Dave

50 to 100 times should’nt cause any problems.

Personally, i reckon bite the bullet and upgrade the firmware and then do a reset to factory defaults.

Rollback if there’s any issues with latest firmware.

OK, tried updating firmware (twice) and it failed both times.  Each time the download cruises along to about 80%, slows, then stops at 90% with a message about a network error (which I don’t think it is).

I’ve tested the link by streaming various youtube videos and they all worked fine.

I have no idea what’s going on.

Dave, Download the Firmware Update and Use a   FlashDrive

 

I have Never Ever upgraded Firmware via Network … i have always used a Flashdrive

100% Success for 2 years now.

Maybe WD Servers are Screwy and Youtubes are Ok.

 

 

My Firmware Update Procedure

  1. Get a small (2gb) Reliable FlashDrive and Format it.

  2. Extract the Firmware to the Root of it.

  3. " Safely Remove the Device from your Computer" don’t just “rip it out”

  4. Disconnect all Network from the WD Device (in my case unplugging the Ethernet cable)

  5. Insert Flashdrive

  6. Click “Update Firmware”

  7. Leave the Room for about 15 Minutes (sitting there and watching it, can increase anxiety)

  8. Upon your return, The Device should be rebooted to the Home Menu

  9. Go to Setup > System > Device Reset > Restore All Settings Back to Factory Defaults

  10. Wait until it’s rebooted … And hope the problem is resolved

1 Like

Hey Joey,

You beat me to it.  I was probably trying it as you were typing.  Unfortunately still no go. Im on 1.9.10 and I got 1.10.13 from the official page ( http://wdc.custhelp.com/app/answers/detail/a_id/5860/),,) loaded it on the root of a USB drive and for some reason I do not get the 'Firmware Update" option pop up.

WD mention this scenario on the aforementioned page but only offer a “contact us if this happens” message.  

I was about to trawl through message boards for a solution.

BTW, not that it really matters, but I didn’t opt for FW 1.13.18 because I read it had all sorts of issues.

Edit:  I tried both USB ports and no luck.  I can see the WD box is reading the drive, just no option to update firmware.

Cheers

Dave

  1. Just to double confirm … when you go to Setup > About  what is the Device Info Number again ?

  2. 2nd option… you could upgrade to 1.13.18 see if that resolves the theme problem and if it does then rollback to 1.9.10

sorry, gotta go, will check back in a few hours to see how you went.

I remembered I had turned off the auto firmware check.  I turned it back on and of course the new firmware tab popped up straight away but that’s because it checked the online server.  I powered the box down and removed the ethernet cable and powered back up.  I inserted the flashdrive with the FW update files in the root…and nothing.

Got me buggered.

Joey - I can confirm the Device Info is reporting 1.09.10.

I’ll give 1.13.18 a go but I don’t think my box is going to recognise that there are FW files on the flashdrive.

i think the Rollback Firmware won’t get you to 1.10.13

i checked the *.ver of the rollback and it’s set to

VERSION=‘2.10.13’
LOCATION=‘wdtvlivegen3.bin’
PKG_LOCATION=‘wdtvlivegen3.pkg’
ROOTFS2=’’

which is higher than your 1.9.10

1 Like

You’ve got to download 1.13.18 from here… and put it on the Flashdrive

http://download.wdc.com/wdtv/wdtvlivegen3_1.13.18.zip

Also TURN OFF … Sync from USB Storage

Setup > Operation >

Make sure only these files are on your Flashdrive … nothing else !

gotta seriously go now … will be back

1 Like

Just thought i’d check in … i’m guessing no luck after my visit 4 hrs ago ? :cry:

JoeySmyth wrote:

Yeah, and my Panasonic Plasma panel is gonna last the 35 Years as quoted by the manufacturer

Why put up the link if you are going to disagree with the article. Lets divide by 3 and say your plasma lasts for 12 years and the write/erase of a flash is 30,000, thats still 300 years or we could be very bold and say its 3000 write/erase which gives us 30 years. I think that puts the whole thing in a better perspective.

and this is all unrealistically assuming there are no faults or defects in materials or manufacturing process.

(previously owned panasonic panel lasted 2 years)

Thanks for your help Joey, it worked great.  I updated to 1.13.18 and then uploaded a new theme fine. 

I’ll play around with the new firmware and then decide later if I’ll roll back.

Thank again