Problem updating firmware on My Book Essential

I just bought a My Book Essential, and after installing the SmartWare & doing the initial backup, I was prompted to install an update.  I followed the instructions to update the drive firmware first.  It seemed to go okay, but when I tried to reboot my computer, as stated in the final step of the instructions, my computer wouldn’t restart.  (My computer was working fine before this).  A message popped up saying that changes had caused damage, & a restore was necessary.  I finally got my computer back on, but now I’m wondering whether the firmware update was successful.  When I hover over the My Book icon on the Home screen, it indicates “Firmware Revision 1019.”  According to the Release Notes on the Product Update page, the latest firmware was  Does this indicate that the update wasn’t successful, or am I comparing apples to oranges?  Is there another way to tell what firmware it has & if the update was successful?  Also, if the update wasn’t successful, could this cause any problems in the future if the update was only “half-completed?”  (I don’t even know if that’s possible, just wondering). 

I also updated the smartware to 1.6.5, which seemed to go okay, but my computer seems to be running slow after all this.

Any help would be greatly appreciated.


I’m having the same problem i update my my book essential, (firmware and software) now nothing really works! The Hard drives says it is read only and and takes for ever to start up. I’ve even tried to use it on other machines and say it has I/O errros when trying to access it.  I’ve install the old and latest versions of WD Smartware and problems still exist. I’ve unistalled and reinstalled all software and drivers, still nothing working. I’ve tried 5 diffrent machines now, the best I can get is a CLUNKY / READONLY drive to show up. That take forever to access. 

I’ll try and get the readonly version on a system with over 2 tb of data, so i can make a back up and try reformating the drive… 

AT This point I wish I would have never upgraded firmware and smartware! IF its not broken DON"T upgrade!

How about this for a FIX! I unistalled all drivers (not sure if you need this or not) but NOT touching it!  AND Plug the power adapter directly into the wall! Why NO CLUE, but i read if you plug your adapter directly into the wall your performance gets better, I was Always using a power strip, But tried it and my drive is not READONLY and it appears to work.