Problem solved. Save my My cloud home. I can't access my device

Well, after a few days of trying during my work breaks, I managed to install OpenMediaVoult on my MCH.
I made several attempts with the available fonts.
The only way I managed to make it work was by restoring the MCH using “#0_AIO_FULL_WD Cloud Offline 1TB” and then installing “wd-mycloud-home-debian”.
The other versions of the previous links did not work.
It’s not the latest version of the OMV, but it finally manages to resurrect my device.

Thanks to everyone who helped.
Now I need to learn more about OpenMediaVault and Linux.

1 Like

I am not satisfied with the previous installation.
I kept searching.
As I said before, my time and knowledge are limited.
After much reading here in the forum and in the Russian forum, after many attempts, many mistakes and some successes, I managed to assemble the puzzle and install OpenMediaVault 6 on my device.

So, I took the liberty and reassembled the step by step detailing the whole process.
In this way, other people with the same or less knowledge than me can recover their lost devices.

How to install OpenMediaVault 6 on My Cloud Home.

Format a good quality bootable flash drive of at least 8GB with MBR partition.
Use Rufus to create the bootable pendrive with the parameters below.
“Free DOS”; MBR; BIOS; FAT32; Just select the “quick format” option.

After creation, delete the contents of the pendrive.
Unzip the contents of the downloaded OMV6 installation file to the root of the pendrive.

To start, the device(My Cloud Home) must be connected to the network.

  1. Insert the flash drive into the device turned off, press RESET and turn on the device, press and hold RESET until the indicator stops flashing.

  2. After 30-50 seconds, open CMD and connect via Telnet through the IP address assigned to the device, port 23. (example: telnet 192.168.1.100)

  3. Enter the command below to create the HDD layout.

makepartshdd.sh

  1. Reboot the device with the command below(When giving the command, the device will reboot.
    At this time, press reset and hold until the lights stop flashing again.
    In the same way as happened in step “1”. Otherwise, the device may restore the previous marking on its own.

cd / ; umount /mnt/* ; sync ; busybox reboot

  1. After booting from the USB stick again, connect again via Telnet. check the partition table with the command below.
    It should contain 21 partitions instead of the factory firmware’s 24, otherwise repeat steps 1-4.

sgdisk /dev/sda -p

  1. Now use the command below to install Debian 11.

installos.sh

  1. Format the user partition with the command below:

make_ext4fs -L UserFolders /dev/sda21

  1. Reboot the device with the command below. At this time, when the device turns off the lights, quickly remove the USB stick and wait.
    “The device must restart with the lights steady, otherwise something has gone wrong and you will have to redo the whole process.”

cd / ; umount /mnt/* ; sync ; busybox reboot

  1. After 30-50 seconds connect via SSH to device IP address, port 22, root login, root password. (example: ssh -p 22 root@192.168.1.100)

  2. Update the date and time with the commands below, one at a time. (Yes, the date and time format looks reversed, but that’s how it is.) (example: date 052217552023).

date MMDDhhmmYYYY
apt update
apt install gnupg
apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 7E7A6C592EF35D13
apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 24863F0C716B980B
apt-get install debian-archive-keyring
apt update

  1. Now you can install OpenMediaVault6 using the command below.

/root/installomv6.sh

  1. The process can be monitored by the CMD. It takes about 10 minutes until everything is downloaded from the Internet and installed.
    There will be an automatic reset at the end.

  2. Now, using the browser, it will be possible to access the device by IP address.
    Login: admin
    Password: openmediavault

  3. Within OMV6, configure the time for your region.
    Configure DNS if it doesn’t load automatically via DHCP.

Other more advanced settings can be done after initial installation, for that you will have to research further.
But the basics have already been done and it will be possible to use the device.

2 Likes

Hi Gledson Glad to know that you recovered your WD my cloud home… I have the exact same issue but the problem with me is I dropped my cloud and my hard disk is not detected. Just wanted to ask if I buy a new hard drive of 4 tb will the images here work the same way??

Hi. If the fall only damaged the HD, it should work.
Because the installation of this system is an adaptation, some OMV features or extensions may not work, you will have to adapt. But it will work as a basic server.
I don’t have my Western anymore.
But if I still had it, I would try installing the synology DSM system.

Here is a simple video, explaining how to install it on an old PC with a monitor.
But from what I’ve seen, it might be possible to access the installation menu via SSH.
If it works, it will be the perfect system to put these Western ■■■■ to good use.
Good luck.

Thanks Once again for your kind help… But what I am asking is that I am stuck with the exact same problem as yours… My led stays on no matter what as soon as I power on. Plus I used some hdd’s at my place which gave me the same status. So today finally I tried to do the instructions provided above in the video by
repairing the partition table via Image’s

and now the WD My cloud home has started blinking but nothing new happens. It’s like it;s slow breathing forever. I just wanted to ask you how did you manage to revive your my cloud home

Recovering with the original western system is not possible. You must follow the step by step I described on May 22nd. Pay close attention to step 4 and step 8, because if you do anything different, the system will not be installed correctly and your device will have a slow breathing light. Pay close attention and follow the step by step. It will work with any HD.

Hey thanks a bunch for your help … But guess what ?? I did recover the western System and now my new hard is running on stock firmware for WD My Cloud HOME

Cheers
:slight_smile:

Cool. You are privileged to have managed to recover your WD to the original system. These are usually lost cases.

Well Yeah I guess I am but guess what? Yesterday I went to buy a new hdd as my last one was damaged and the one I used to recover was just 1TB so , I went to the market and asked the guy if I can test the hdd first on myhome cloud , he agreed and VOILA my hdd of storage 6tb from seagate Skyhawk worked flawlessly and now I am all good with the stock firmware…
Thanks again for your guidance as well Gledson. Really appreciate it

It is great that you could recover the My Cloud Home with a blank disk, but that cannot be done without copying the boot sectors to a new disk as it has been documented many times before in this subforum with the 24 partitions of the MCH. The MCH Duo has built in emmc flash memory that retained the bootable sectors so it could recover from a blank disk while the MCH cannot.

This is the MCH disk partitions from a thread a few years back if you search the forum.

This is just FYI for MCH owners who think they can swap MCH with a blank disk without disk clone with dd.

Well being honest I did try this method but I guess I did something wrong or it was out of my league so I failed in doing so by this method. But flashing the firmware directly with Telnet did the magic for me.

Good to know this worked for you but there are many or most in the West who would not boot and make partitions HDD with a script and hack made by Russians - some of whom may be well meaning, but it is still a hack and of an old MCH firmware.