Problem running unlock application when starting the portable hard disk 500 GB mypassport 0740


I run my passport drive 500 GB always very well without installing the software but unlocking from the virtual CD with the drive. Now, suddenly I found that after plugging the drive there is no virtual CD drive. In my computer it shows a icon of CD drive but there is no application of unlock or anyother. When I tried to open this drive it appears a dialog box which says that:

I:\ is not acessible
The request could not be performed because of an I/O device error.

In the device manager it shows the drive “mypassport”, But no “mypassport” drive in my computer and I also can not find any way to access my drive.

Can anybody help me to access my drive and to recover my datas?



How is the drive showing on disk management?

Are you able to test the drive with a different cable?

Also test the drive on a desktop computer using the back USB ports of the computer.

Please note that I/O device error is normally referred to input/output errors