PROBLEM, need help wdtv + router TP-Link TL-WR842ND


need your assitance and help, I have the first generation of WDTV, and currently I want to create a media server using TP-Link router TL-WR842ND.

I attached my 2TB seagate to the router and start create media server from the menu in the router (via computer), and from my WDTV I connect it via RJ45 cable to the router.

it all works well, the router read my hard disk and my media server is created. WDTV managed to read the media server, BUT it seems they could not read the whole hard disk. they only managed to read one folder in the hard disk where it should have 7 folders.

I tried to connect my hard disk to WDTV via USB and there is no problem.

Does anybody has the same experience? how to solve this?

PS. I also tried to use my ipad with aceplayer apps to read the media server and it has the same problem.

thanks in advance.



Make sure that you are sharing the whole drive, not only that folder.

Also make sure that you have the latest firmware on all the devices and as a recommendation try resetting your router.