Problem in opening files on WDTVLiveHub

since I bought this Mac, I’v been living like **bleep** with it!

all the videos on my WDTVLiveHub are not working on my TV anymore :frowning: since I connected it to my Mac!

I downloaded MPlayer but the default player on mac is Quick Time! I can open my videos on my computer using MPlayer but not on my TV!

all the videos are AVI files! even the music I have on my LiveHub is not playing on the TV anymore!

can someone help please?


 even the music I have on my LiveHub is not playing on the TV anymore!

Music stored on your Live Hub isn’t playing any more since you bought a Mac?   There has to be something else going on… The MAC doesn’t have anything to do with the files that are stored on the HUb…

Hi I don’t know what’s happening! my WDTVLive Hub is so silent! I play a music file, no sound goes out!

my videos, since I connected my LiveHub to the new desktop I bought, which a Mac OS snow Leopard, my videos are not working on my TV!

do u think the problem is in the Hub or in the fact that I connected it to a Mac?

Are you trying to steam the vids via media server or are you browsing folders to access them?  Have you tried copying the same files to the HUBs internal drive to see if they will play?

all the videos were already on the hubs internal drive! and nothing is working!

all the videos were already on the hubs internal drive! and nothing is working! and the videos I’m steaming them via media server

I feel really desperate! I will be very angry if there’s a problem with the hub!

I bought it on Xmas! so it’s bright new!

What type of vids do you have, mkv, mp4, vob, iso, etc?


I did some search on internet and I found out that the AVI can be read by MPlayer or VLC. SO I downloaded both. But both still not working on my hub.

I’m able to open them on my Mac but not on my TV hub!

Ok, a couple more question, are these home movies or movies that you converted to AVI?  What codec is your AVI?  If you don’t know, open the video in VLC then press Ctrl+J, (or right click on VLC select “Interface \ Codec Information”), then in the new window click on “Codec details”.   Look under video and see what it says beside “Codec”.

You can also try downloading THIS.  It is just a dummy avi file, copy it to the HUB and see if it will play.  If it plays you should see the words “Your Movie” come up in red.

I tried, nothing worked. is the codec

I think the problem comes from my LiveHub not from my files.

Because I copied a movie from my labtop which is a WIndows XP on the LiveHub. It’s not working neither. I copied music from my Labtop to my Hub, the same, not working!

same problem: everything works on both my computers, my Mac and my PC labtop. but nothing works on the LiveHub!

also the dummy.avi file didn’t work

Yeah, if the dummy file didn’t work then it might be a problem with the HUB. You may want to try and reflash the firmware.

So try this, download the firmware from HERE, then extract the 3 files of the zip file to the root of a USB thumbdrive, then open the “wdtvlivehub.ver” file and change the Version number to a higher number.


From: VERSION='2.03.24’LOCATION='wdtvlivehub.bin’PKG_LOCATION=‘wdtvlivehub.pkg’

To: VERSION='2.03.30’LOCATION='wdtvlivehub.bin’PKG_LOCATION=‘wdtvlivehub.pkg’

Then take the thumbdrive to the HUB and plug it in and turn the HUB on.  When the main screen comes up it shoud now say something like “New Firmware”, select it then follow the screen to update.

thanx for the help.

I’m trying to open the link that u sent me! it’s opening a blank page

Wait a minute.  

Let’s get back to the basics.

Are you connected via HDMI or COMPONENT or COMPOSITE or SPDIF?

If HDMI or SPIDIF, what type of device are you connected to?   Have you correctly set the DIGITAL or STEREO format in the Audio/Video settings?

If COMPONENT or COMPOSITE, have you made sure you set the audio output to STEREO?

Sorry, try this HERE.

I have my LiveHb connected to my TV with a HDMI!

ANd it was working before!

and there’s something, even the original video on the LiveHub are not working!

You didn’t answer the other questions.

Since it’s TV, you should have the AUDIO MODE set to STEREO on the Hub.