Problem in connecting Passport SSD 1T to Big Sur

I used a Passport SSD 1T external drive with my MacBook Air with MacOS Catalina, they worked well.

However, after I upgraded my MacBook to Big Sur, the SSD drive can’t be read or write by the MacBook with Big Sur.

Anyone has the same problem?

Any solution to fix it?

1 Like

Hey WisonCheung, i’m having too the same exact problem with the same external SSD (My Passport SSD 1To) you are using, since i updated from Catalina to Macos Big Sur everything was fine i was able to move files easily from the drive to my Macbook Pro 2019 and vice versa, until last week i noticed that when i plugged my ssd it took a very long time compared to the usual in order to be read, and when i try to open a folder it stays on loading and can’t do anything even eject it isn’t doable. When i do a diagnosis using the drive utilities of WD, it gives me no errors as it is working perfectly, so I hope WD may find a solution to this problem.

1 Like

I have the same issue with my 1TB My Passport SSD. It also started after upgrading from Catalina to Big Sur. I don’t know if it is an Apple or WD bug, but the workaround is to turn off UAS for the SSD. Open up WD Discovery, select the Storage tab, select the preferences (gear icon) for the drive, then the UAS option. Turn off UAS and eject/re-mount the drive (or just reboot after turning it off). Once UAS is off, the drive should function normally, if slower.

2 Likes

I have the same problem!

Thanks a lot. It works.

I upgraded to Big Sur last week. Now I am unable to unlock my WD external hard drive. I don’t seem to be able to do anything at all with the hard drive. It seems as if it wants me to download the original software. Error message tells me to install CD. Never had a CD. My laptop doesn’t have a disk drive. I would appreciate ideas on next steps.

Please could you explain a little better? I have not understood thank you.

Install WD Discovery per this: Install Instructions

Then follow the steps from my first post. These screen shots highlight what to select. For this example, my SSD is named “Temp”.


To get to the below panel, you click on the “UAS” option that appears after clicking on the gear icon. It will show “UAS (ON)” or “UAS (OFF)” depending on the current setting (off in my case).

1 Like

When I install it it doesn’t recognize the disk!

Thanks, i’ve been really in trouble with this problem, hope WD or Apple fixes this UAS Problem.

What format does your WD external hard drive? If it is formatted to NTFS, you have to download a latest NTFS driver to read and write.
But, if your Big Sur can’t even read or connect to the hard drive, I have no idea.

I have a 8TB Cloud Home and have a problem with that it is disconnecting. After updating to to Big Sure it worked but now a couple of days after the problem appears.

Hi There!!

Had the same problem… this was my solution

I installed both of this:

  • WD Drive Utilities for Mac
  • WD Security for Mac

Open them after installing and you will be able unlock from them!!! :smiley:
Hope it works for you

Thank you for your reply. I have tried downloading and opening this software, however I am still getting the following error message.
Screen Shot 2020-11-30 at 7.18.45 PM.png

So, I cannot get to the screen that asks for my password. I would appreciate additional ideas.

Donna

Thank you for your reply. The original box says formatted HFS+J for Mac OS x Lion or Mountain Lion. Does that mean Big Sur won’t be able to connect to the hard drive any longer?

I downloaded WD utilities and WD Security software. I continue to get the following error message:

Screen Shot 2020-11-30 at 7.18.45 PM.png

Any comments/ additional ideas you have will be appreciated.

Donna

Hi there,
So what I did was the following:

After installing the apps I went to Applications clicked on WD Security as you can see on the screenshot.

It will open what you see in the screen…now I have that dialoged box because I decided to delete using a password to access it, but before I manage to do so, the same box would appear asking for your password to unlock it.

Hope this works, if not and you need to talk because I know how frustrating messages can be I can join a zoom meeting. Just let me know.