Problem formatting MyBook 3TB drive as Fat32 using Disk Utility

Boy oh boy, this one has been driving me nuts!

My brother bought a MyBook 3TB drive for Mac, but he wants to use it to back up his Sony Playstation.

This requires the drive to be formatted as “Fat32”. Disk Utility’s steps look fairly straightforward, but one problem is that, under “OPTIONS”, I need to select “Master Boot Record” (according to WD’s instructions) - - only it is grayed out. This was the case on my friend’s Mac too. 

I am using a brand-new iMac running Lion.

Can anybody please help me figure out why Master Boot Record is not an optiion, and how I can make it BE an option?

THANK YOU in advance.

Hi, what options can you select?

1 Like

Hi Alucardx23,

My choices are: 

*GUID Partition table (for Intel-based Macs)

*Apple Partition Map (for for PowerPC-based Macs)

*Master Boot Record (for DOS & Windows-based computers).

The link that you provided (from WD’s own instructions) says that I need to select “Master Boot Record”, and yet it is always grayed out when I have followed the instructions. So this option is not available to me. Just for yucks I tried using one of the other options once, and my brother’s PlayStation didn’t “see” that the drive existed when we hooked it up.

THANK YOU for trying to help me!

If you have access to a windows computer, you can download Easeus partition master Home Edition. Check the link below for the download link.


Steps on how to use it.

You can also check the video below, it might help.

1 Like

Thank you for that suggestion; unfortunately it seems as if everybody I know has a Mac! Hard to believe, I know. Maybe my parent’s neighbor’s have a PC. It sounds like this option is my last resort… though I sure wish I understood why the instructions that Western Digital recommend  for reformatting on a Mac do not seem to apply to me.

Again, thank you for your help, I appreciate your time and effort!

Well, I finally formatted my MyBook as Fat32 - using my old PowerMac that is running Tiger (OSX 10.4). Suddenly the elusive “Master Boot Record” was no longer grayed out, and I was able to do just what I wanted to do. WHY? Who knows. I’m just glad it worked!

Don’t know if this will work for the PS3 but it did for the WD media player:

Ran into similar problem on Mac. Select “partition” then select “1 partition” and this is the part I stumbled upon in “options” for my purposes (PC/Mac/WD media player compatibility) select GUI option (sorry don’t remember full wording but it’s the top choice when you get there). Apply and voila the drive is now FAT32. Hope this saves everyone else the hours I wasted before stumbling onto this.