Problem Copying Media to Internal Storage

New user here - just got my Live Hub for Christmas. I was thrilled by how easily everything worked. Plugged an external hard drive in and it recognized it right away. Played movies off of it no problem. Copied files to the Live Hub and found metadata for my movies without any issues. These things rarely just “work” for me without problems, so I was pleasantly surprised at the apparent reliability of this machine.

That is, until tonight, and now I’m a little spooked. Over the past few weeks, after initially copying a handful of movies to the Hub just to make sure everything was in working order, I’ve been gradually ripping my entire DVD collection using Handbrake. It’s been no small task, but I finally finished tonight. My plan was to copy them all over to the Hub all at once overnight.

Plugged in the external hard drive, selected all the movies and began copying. After about five minutes, I got a strange error message I’ve never seen before: “Copy fail. Write fail. Check the destination source”. I rebooted the Hub and tried again - got the same message. I reluctantly formatted it (wasn’t a huge deal, because the few movies that were on it are also on my external hard drive, so all I’ve lost is the little extra time it’ll take to re-copy them), tried copying and again got the same error message. I’m starting to get very frustrated, and a little worried.

Searched the forum and couldn’t find any other discussion on this problem. I have no idea what to do! Any help would be greatly appreciated, and thanks.

Try copying individual movies and see if you get the same message.  If that doesn’t work, try pluging the external drive into your PC & copying the files from the PC to the HUB.  Also, while you have it pluged into the PC check the permissions of the files & folders.


  1. Try a different USB hard drive, or a USB thumb drive, or copying using the network (Ethernet is faster than wired unless you have an “N” router and “N” USB adapter)

  2. RESET the device (reset button under front USB. Hold 10 seconds. Resets to factory defaults)

  3. Upgrade to latest firmware (I always leave the firmware upgrade option on so it notifies me)

*basically you want to determine if your WD device is the problem or if it’s the drive you are plugging in.

**I am adding my DVD-Video files as ISO Images which are an EXACT copy of the original disc (average 7GB per disc). Use the free programs “passkey lite” (dvdfab) and “imgburn”. The ISO image uses more space than ripping, but there is no loss of quality and the menus are intact. The internal drive holds 130 DVD’s.


I have lots of video so I added a 2TB WD Elements. It’s great. It will turn itself OFF and ON automatically with the box so you never have to touch it. (I hook it up to my computer, copy my DVD images, then hook it to my WDHUB, then sort things out via my PC for moving/folders then add the Content using the remote).

If you are able, use an Ethernet cable instead of Wi-Fi. (my wi-fi is about 3MB/second. Ethernet is 10MB/sec. wi-fi with “N” capable router AND “N” USB wi-fi adapter can get over 20MB/sec. the Elements drive is 24MB/sec)

You said “Ethernet is 10MB/sec. wi-fi with “N” capable router AND “N” USB wi-fi adapter can get over 20MB/sec.”

Are these speeds true?  Wireless N is twice as fast as Ethernet?  So if someone has a N USB adapter there’d be no reason at all to use the ethernet port, am I interpreting that right?  Can someone please give a second opinion on this?

I’m planning to install an ethernet port in my rec room to hook the Hub into my network but if I can buy a simple dongle and avoid cutting holes in my wall and running cable that would be outstanding…  (Except that I can’t use an external drive on that USB port now.  Grrrrr)

Thanks for the replies, guys.

Alright, so the plot thickened this morning. I just updated the firmware and decided to give this another shot. Now, I can’t even play videos off the external hard drive directly. I’ll plug in the drive, it appears to recognize the drive and tells me it’s updating the media library, and after a bit the number of files does change (“0 new files” to “450 new files”). However, when I try to open the ‘Files’ section, it tells me there’s no media found in that folder. Despite the “450 new files” found, when I try to open the folder, it’s empty.

I’ve now tried this with both my external hard drive and a thumb drive with an individual film on it. Tried both of these on both USB ports. So I guess it’s a problem with the Hub? Not sure what could’ve caused this so suddenly, though.

I don’t have a PC, so can’t copy the files that way either. What should my next course of action be?

And thanks again!

Ah, forgot to say that I did also format and reset the device before updating the firmware and trying all of this.

AD613: Wireless-n CAN be faster, but to obtain that speed you must consider the entire network. What if your Wireless-n router is talking to the hub via a wi-fi wireless-n dongle (good), and the wireless-n router is connected to a PC that only has a 100Mb/s ethernet port, or the ethernet ports on the ‘n’ router are not gigabit but only 100Mb/s. Then the speed of moving data from the PC to the hub is limited by the 100Mb/s (10MB/s) ethernet speeds even if the radio link between router and hub is capable of higher speeds.

I’ve seen medium priced wireless-N routers that don’t have gigabit ethernet (GbE) ports but only fast ethernet (100Mb/s). So moving data from broadband internet via the ‘n’ radio might be fast, but slower when moving data from another device on the network via the router’s slower ethernet ports.

In my case, to realize higher speeds all around, I would need to replace the cable modem (now 100Mb/s on ethernet), and the router (now only 100Mb/s on its ports), the primary PC (now only 100Mb/s on its ethernet port). Nope, I’ll just wait a while, and sooner or later all my equipment will get upgraded or replaced and some day I’ll be faster.

So, assuming I won’t be using Netflix or any of the intensive streaming online services (as my modem is connected to my router with ethernet cable), as long as everything downstream from my router is running wireless-N (router, laptop, Hub via adapter) I should get those fast speeds, right?

For now I don’t plan on having any external storage on my network accessible to the Hub.  If I were to in the future, there are or will be probably some wireless-N capable NAS products…  But that’s in the future for me.

I like to keep things simple. The simple way to test the speed is to copy a big file.


1 GB movie file at 10 MB/s = 100 seconds (give or take some percentage for overhead and such).

If the file goes in 50 seconds or less then you are cooking along pretty good.

Aren’t throughputs usually measured in Mbps rather than MBps (Megabits rather than MegaBytes)? For me, using wireless-g, I get 1GB file transferred in one hour. This I take to be about 2.2 Mbps. 1Gigabyte = 8 Gigabits = 8,000 Megabits (approx) 8000 Megabits / 3600 seconds = 2.2 Megabits/second (approx)

It would be less confusing (for me anyways) if the answer was ‘yes, wireless-N is faster’ or ‘no, wireless-N is not faster’ than ethernet.  :)    Looks like I’ll be waiting for that one…  :)

AD613 wrote:

It would be less confusing (for me anyways) if the answer was ‘yes, wireless-N is faster’ or ‘no, wireless-N is not faster’ than ethernet.  :)    Looks like I’ll be waiting for that one…  :)

It’s faster except when it isn’t.  :wink:

10BaseT Original ethernet  (10 Mb/s baseband on twisted pair), 10 Mb/s (outdated, seldom seen these days)

100BaseT faster ethernet, 100 Mb/s (this is still the most common on most consumer gadgets these days)

1000BaseT gigabit ethernet (GbE) is 1000Mb/s (appears on many higher quality consumer devices these days)

Wireless 802.11n Theoretical 300 Mb/s when configured in channel bonding mode (using two adjacent radio channels to double the bandwidth - but problematic in crowded RF environments).

Wireless 802.11n Normally 130-150Mb/s when configured in traditional single-channel mode (the default)

So you see, Wireless-N can be faster than 100Mb/s ethernet, slower than GbE.

You must consider the entire network.

To take FULL advantage of the speed available with Wireless-N, the rest of the network needs to be GbE.

Wireless-N is good when used on a 100 Mb/s ethernet network because then the wireless link is as fast or faster than the other parts of the network and won’t slow them down.

The old Wireless-G wi-fi standard is slower than 100 Mb/s and would be a choke point on a 100Mb/s or faster ethernet network.

How about this…

DSL modem, connected with ethernet cable to NetGear RangeMax Dual Band Wireless-N router (5GHz settings are “up to 300 Mbps”)

HP Laptop, connected wirelessly (N) to router on 5GHz band.

The decision I have to make : To run ethernet cable from router to WDTV Live Hub or purchase Wireless-N adapter for Hub.  Any opinions?

Do you see any choke points or issues with this setup?  As I said, in the future I might add a NAS to this, but that’s not in the budget for now…

Not to be a Moosehead or anything, but here goes…

1 - It’s ALL ethernet.  Wired or wireless.

2 - I haven’t seen a single citation of a device in the entire thread that - if configured properly and having good signal - would cause lag/stutter.  The slowest device mentioned - if not mistaken - is 54Mbps.  Plenty of bandwidth for streaming; again if configured correctly (for example not as a repeater which halves the bandwidth you see reported).

3 - Forget everything else: if you CAN/have the option of having a hard wire in place do so.  Especially when the topic is streaming.  Right wrong or indifferent, wireless signal varies and not all wireless devices play together as seamlessly as they should.

Hope you got your original problem solved.



For clarity, the advice to ALWAYS use a hard wire requires a little practical interpretation.  I’n not expecting anyone to require a wire to a laptop or tablet or pacemaker :slight_smile:  But for the access points (APs) routers, hubs, switches, servers, desktops - wire it!



Photonboy wrote:




  1. RESET the device (reset button under front USB. Hold 10 seconds. Resets to factory defaults)



Do not hold the reset button for 10 seconds it changes the unit from PAL to NTSC or vice versa, a 1 second press and release is adequate for a reset.