Problem connecting with wd2go on My Book Live 2To


I just bough a WD live 2To and set all i could to get access from DLNA (with Twonky), local Computers, Mobile (Wb2go for Androd & iPhone) and Web.

All works except wd2go on the net (from local computer).

Here is an error message shown :

I can sign in, Access My WD Live, write my network drive password and then see my shared folders. But when i try to click on “+ Open in Explorer” it says “Le nom du réseau est introuvable” (Google translate : The network name can not be found).

=> I tried to search for same errors on the forums but didn’t find anything…

Please anyone help me… This Drive looks so nice… I would not like to take it back to my “dealer”…

Thanks by advance…

NB : I tried also on XP and Linux session on my local computer…

You do not mention if you setup the mobile access.

See the manual’s “Setting Up Mobile Access”.


If i was not “clear” in my first message, i already activated network access, else i couldn’t access my wdl with app2go mobile app… It works with app2go mobile (either on iPhone and Android phone) but don’t work with web site as viewed on my screen copy…

Help !!!


  • I already set Remote Access.

  • I can access to the web site wd2go whit my user / pwd

  • I see my WD Live 2Tb

  • When I click on my WD Live 2Tb i can see my shared folders (as you can see on my picture posted below)

  • When i click on any of my shared folder it say “Le nom de réseau est introuvable” either if the adresse is local (’…)) or internet with my external WD Live adress.

Please give me a help !!!

If anyone can try, i can give a public access to my drive for a new user with one mail.

So this “anyone” will be able to try wd2go access to my drive…

Thanks by advance.