Problem connecting to MBL over wifi with WD2Go app on iPad2

I bought a 2TB MyBook Live and have managed to connect it up and using fine.

On my iPhone 5, I can connect by WiFi on the same network and on 3G fine.  No issues.

I can connec to the drive from work using the wd2go website as well.

However, when using either my iPad Mini or iPad 2 with wifi on the same network as the MBL, the WD2go app detects my drive on the network but when I click on it, it comes up with an error “Unable to Connect to Device”.  However, my iphone under the same scenario works fine.

I’ve downloaded the latest app and also the latest updates on the MBL.

HELP… thanks.

The same thing happened to me, it can take a couple of minutes to link the wd2go accounts. If you are still having the same problem, try uninstalling the wd2go app and creating a new account from the my book dashboard. 

HI. I’ve tried both … still no go :frowning:

Try pressing the reset button on the back for the my book for 4 seconds, if that doesn’t work backup your files and do a factory restore from the my book dashboard.