Problem connecting to Mac for use with Time Machine

From what I’ve already read here, I suspect that my problem arises from my router, which is a HUAWEI EchoLife HG532 ADSL/router supplied by my ISP, TalkTalk in the UK.

When I first connected the MBL, everything looked OK. MyBookLive and MyBookLive-backup appeared as Mac servers in the “shared” section of the Finder sidebar. Bonjour could see it. WD Quick View could see it. Time Machine’s “set backup disk” panel could see it. From the Finder, I can connect as “guest” and the Public share mounts as a remote drive on the desktop (I have that Finder option set). I can see the data on the MBL (I stored a couple of photos there, as a test).

BUT, Quick View (and Safari using Bonjour) won’t always open the Dashboard, and when I try to open the drive from Quick View (and sometimes from the Finder), things start to go wrong. The same thing happens if I try to start a TM backup. I get “connection failed” messages, and MyBookLive disappears from the finder sidebar. Bonjour can’t see it any more; Quick View can’t see it any more. Meanwhile, the Public share remains mounted and accessible on the desktop.

After a while, or more quickly if I relaunch the Finder, the drive appears again in the Finder sidebar, this time as “mybooklive” (no capitals) and saying it’s a PC server. Sometimes I can open it from there, and sometimes not (connection failed).

All this time, the Public share is still mounted and accessible on the desktop.

My router says that it has assigned 4 IP addresses on the Ethernet LAN, even though there are only 2 things plugged in.

Router screenshot LAN

I can access the Dashboard if I use the highlighted IP address directly, but not using the server name.

QoS is disabled; UPnP is enabled. (I’ve seen these terms mentioned here while I was researching)

Firewall setting is to the ISP’s custom setting, but I don’t know what that is.

I have no idea how to set a static IP address for the port with the MBL, or I would have tried that.

Any help will be gratefully received.

Thanks.

… I should also mention that the MBL fails to assign a code for mobile access (unknown error), and also won’t register remote access.

Hi, update the MBL with the latest firmware. 

http://wdc.custhelp.com/app/answers/detail/a_id/5735/session/L3RpbWUvMTM0MDA0MzYxMC9zaWQvREdCbk8tLWs%3D

I should click a non-kudos star on my own post for not having said that the firmware appears to be up to date.

The Dashboard says that the MBL has good internet access, and the “check for updates” said that it was up to date. Just in case that wasn’t true, I checked myself: the MBL says that it has version MyBookLive 02.11.09-053 : Core F/W and the manual firmware page says that 02.11.09-053 is the latest version. :frowning:

I did check that because a friend at work recently bought one for the same purpose, and told me that he’d had to install a firmware update.

Even so, I don’t suppose it can make anything worse if I download the latest version and install it manually. I’m downloading it now, and I’ll report back shortly. After all, I don’t know exactly how the firmware was loaded originally, and I do know that sometimes Mac OS incremental updates mess things up, and that can be fixed by downloading a composite update.

OK, I installed that firmware version manually, supposedly with the same serial number, and everything disappeared (except the dashboard connection, which I think was pretty clever). I rebooted the router, and things looked as before. I selected the MBL for Time Machine backup and told it to start backing up. It was taking a while (as before) with nothing happening so I tried to open the drive from Quick View. Hey Presto and the MBL disappeared from the Finder sidebar.

But then… Time Machine managed to attach the drive and it’s backing up now. The MBL has reappeared on the Finder sidebar, once again as a PC server, and the Public Share is mounted. Also the Time Machine Backups drive. Quick View can still see it; Bonjour can still see it. The Dashboard connects using the “mybooklive.local” address… no, it doesn’t. It’s gone.

Now Bonjour doesn’t see it and Quick View doesn’t see it. Time Machine says it’s still backing up (and the numbers are going up on the display). Finder says that “connection failed” on the PC server mybooklive. The Public share is still mounted and accessible. The MBL dashboard is still accessible using the 128 IP address.

There’s another “Network link down” on the Dashboard error log (I should have mentioned those, too).

It has given me access codes, and I’ve successfully connected to the MBL from my Android phone using WD2GO and WD Photos.

It has sent me an email for remote access, though when I logged in the URL changed to the IP address of the drive so I’ll have to try that from somewhere else.

Meanwhile, it seems to be doing what I need it to do, even if not all the connectivity is working. The proof will be when TM finishes this backup and tries the next one.

There’s a quicker way: I’ll try the laptop.

No, TM on the laptop doesn’t see the MBL now, neither wirelessly nor over Ethernet.

So that firmware update was quite a help, but it doesn’t seem to have solved all the problems.

Thanks for the advice so far, Alucardx23. I have to say that IMO the MBL should have known to upgrade its own firmware. If you have any other advice about how to stabilise the connections, that would be great.

Of course, it might be as simple as “don’t try to open the drive from Quick View”, but I’m not rebooting the router until the b/u has completed.

More tomorrow!

Well OK, I can at least make a Time Machine backup, which is a vast improvement, but the configuration/connection is still flaky. To make the Time Machine backup work, I have to reboot the router and make sure the MBL is awake (green light not blue), because attempting to access it in some ways (e.g. by trying to access the dashboard using the server name instead of the IP address) when it’s on standby just trashes the connection instead of waking the MBL up. Then I have to initiate the backup quickly before the config changes. Although the Public share is a stable connection once it’s mounted, I have to mount it quickly, or I can’t access it.

I can still see the drive from my Android phone, both from home (on the local wifi network) and elsewhere.

So thanks very much for the help so far, but I still need some more assistance to make the network configuration stable.

Take TM completely out of the equation for a start. Take a look at my postings re: MBL and mapped shares.

Well, thanks, but no thanks. I have a USB external drive that’s suitable for TM over a direct connection to my iMac, but strapping an external drive to the MacBook sort of defeats the purpose of having a laptop. I bought the MBL specifically to use with TM. A work colleague has a Mac, and recently bought a MBL for the same reason, and he has no problems. (Aside from the need to apply a firmware update, that is. He did mention that to me, but didn’t say that the update required had the same version number as the firmware that was already installed.)

It’s becoming clear to me that it is no coincidence that Apple’s Time Capsule NAS device comes bundled with a router.

I can see that the MBL is somehow acquiring more than one IP address. When I (successfully) made another TM backup just before I logged on here, I got a message that something else on the network was using my computer’s IP address. Don’t know what. This time, I turned the AirPort off before I started, and with the laptop powered down there should only have been two IP addresses issued by the router: the MBL and my iMac’s Ethernet.

So basically I’m now looking for advice on how to configure my router to make the thing work the way it should.

Here’s the router’s list of iP addresses now:

The IP address ending .2 is the one that my iMac had been using when that error popped up soon after the TM backup started. It’s now using the one ending .5, and it seems to have made that switch all by itself. I have worked out that the .6 IP address, which says it’s a dhcpcd 4.0.15 rather than a “Computer” addresses the Public Share on the MBL.

I would look for help from my ISP, because it’s their router, but I doubt that they have enough knowlege about (1) Macs, (2) Time Machine, and (3) the WD-MBL. At least a lot of people here have Macs, and surely most routers have similar configuration options, even if they’re not all configured the same way out of the box.

Well all I can say is good look with your quest.  I suggest you have a good read on this forum though at just how many people have issues with trying to use TM with MBL.  You do know Apple don’t support TM backing up to a NAS don’t you?  I was just about to return MBL for a refund when I tried taking TM out of the loop - job sorted.  You can’t back up TM wirelessly in any event to MBL as it just won’t work so don’t understand why you say you can use a USB for your iMac but not a Lappy?

I did a quick google search on this router. I see a number of threads about Apple Airplay not working. The Talk Talk forums told people to return the router to them if they have that problem (via their ticketing system). Since Airplay uses Bonjour as it’s protocols for discovery, sounds like this points to the router. We noticed that their was a flavor of router in the US from Actiontech that had similar issues (the NAT table was too short, so it would constantly lose connection). I would recommend contacting the router manufacturer or your ISP to see if they have any ideas. You may want to check for a firmware update on the router as well.

Thanks for your good wishes, Jacko. Yes, I know that Apple don’t actually support TM backing up to a NAS (with the exception of their own Time Capsule, of course), but I’d read that the WD-MBL worked and my work friend is doing very nicely with it. I’m sure he said it worked OK wirelessly, but I’ll double-check that when I see him on Friday.

Of course I can use a USB drive with the laptop, but that ties the laptop to a cable. TM is supposed to b/u every hour in the background, and I don’t want to have to run to the living room to plug the lappy in every time it, or I, want to make a b/u.

Thanks, Tony. That’s very interesting. I don’t use AirPlay very often, but I have an Airport Express for that purpose. I’d decided that it was on the blink because it vanishes from the iTunes output menu a while after it’s switched on, and the Airport Utility can’t find it either when that happens, for all the light on the front is green. I thought it was just lying to me, so I bought another one (which is still in its box). Now, it seems, perhaps the router is to blame for that as well.

I’ll get on to TalkTalk.

Time Macine Editor, free download, let’s you set your own schedule, once a day, once a week etc.

Yes, I have something similar in fact: Time Machine Scheduler. Even so, it doesn’t work on NAS unless the b/u drive connects automatically, and it won’t b/u to a USB drive unless I plug it in.

I think you will arouse a lot of interest on this forum if you are able to successfully carry out wireless TM backups that are restorable. Speaking for myself I wanted MBL to use as a NAS, therefore as it’s only a single HD I consider using it for data and backups to be just to risky.

I’m sure that it will arouse a lot of interest. People who don’t have problems don’t visit help forums, so it’s only because my workmate who sits next to me says he has a faultless wireless setup (he only strings a cable if he knows that he has a big file to transfer, such as his iPhoto library) that a fix is in sight. He tells me that his ISP is PlusNet, and everything works fine with the router that they supplied, configured as it came out of the box. Tomorrow, he will tell me the make and model of his router.

It’s always easier if you can point at something and say “this works, make mine the same.”

Since the demise of my Time Capsule I’ve subscribed to iTunes Match, so my music is safe. I recommend it, especially for people who have been buying musing from ITMS for a long time. It allows you to upgrade all the music you’ve already bought to higher quality encoding, without DRM.

Do please keep us all posted as to progress. Personally I’ve never used wireless on my iMac as I don’t need it, preferring instead to rely on Ethernet.

OK, my colleague’s ISP is PlusNet, and his router is a Thomson Tg585 v7.

He’s also running Lion. I don’t think that makes as much difference as the router though. Although I’ve stuck to Snow Leopard, I’ve seen some updates to my software in the app store in the last couple of weeks that require Lion, so I’ll be upgrading from Snow Leopard soon whatever happens.

Next step: contact TalkTalk. I’ll keep you all informed of progress.

Still not convinced the router is you problem - I have tried three different routers with my MBL - a Belkin, Netgear and a BT HomeHub which by the way is a Thomson.  All routers have performed very similarly.

One thing I have noticed, and this is following one of your posts.  I ticked the box in Finder preferences to mount the shares on the Desktop.  However, whilst this works in a fashion it is has caused unforeseen problems - mainly sleep issues again.  If MBL is asleep on Mac wakeup then the shares don’t mount anyway, I have to wake MBL myself before the shares mount. I don’t shut the Mac down but use instead the default, which as you know is “sleep”.  With the shares mounted MBL either won’t enter sleep or if it does it tends to wake up again at odd periods.  I don’t have the option ticked “wake for network access” either on my iMac so not sure what is causing it.  If I eject the shares then MBL sleeps as normal.  

I do think “sleep” for MBL needs more development work for Mac’s.

I’m not going into sleep/not-sleep. I’ve noticed some contradictory behaviour. Sometime the MBL fails to waken, which causes the connection to drop; other times it seems to wake up for no reason.

I’m sure that the router must have something to do with it, but also its configuration. When the “Mac server” shares drop from the finder and the MBL disappears from Bonjour, it’s no longer possible to find the Dashboard using the server name, only by trying the iP address (which I’m sure sometimes changes). As the DNS server is part of the router function (isn’t it?) that seems to point a finger.  And it’s rebooting the router, not the Mac, that sets stuff straight for a little while.

I don’t have the time or inclination to compose an email to my ISP today, but I plan to ask them about configuring the existing router as well as the possibility of a replacement. They should be able to find out what settings PlusNet send out as defaults. I also plan to direct them to this thread.