Presumed Bricked My Cloud - Steady White LED

So it looks like I have the dreaded white LED of death. I’m almost certain I have a Gen 1, it’s at least 3 years old, probably more.

I wonder if you guys would mind helping confirming the diagnosis and suggest a correct course of action. I have read many of the bricked drive / recovery posts and I want to confirm what the latest thoughts are on both recovery and then unbricking of the drive.

The LED on the front is solid white and has been for over 24 hrs, I have tried the 4 second reset and literally nothing happened. I will try the 40 reset tonight (I wanted to give 24 hrs plus to see if it was running check disk. The router shows the device as disconnected within the Asus software, but the LED is illuminated associated with that port. Additionally, the network port on the back of the drive is flashing green (but not amber). I can’t seem to get dashboard from either of my computers, so I’m suspecting some sort of firmware corruption (given that I think the networking side of things is ok). I can also hear the driving spinning what appears to be normally.

So I’d like to be able to first of all recover what is on there… Paragons extFS for windows appears to be the first port of call for recovery purposes. I presume this will require me to remove the drive from the case and connect it up via Sata / Sata dock. I presume there are copy / paste functions within the paragon software? Are there any other latest and greatest methods assuming zero connectivity to the device?

Once I have hopefully recovered the data, I’d like to unbrick it. Again, are there any later developments to those mentioned here:


Have you looked at the User Manual for your generation of My Cloud? First generation firmware is 04.xx.xx and second is 02.xx.xx .

Here is the 1st generation User Manual, look at LEDs and what a white front light represents.

Yep, checked the manual. It’s a little difficult to discern whether it is a solid white or solid yellow light. I know there is no failure indication for solid yellow but a quick search does bring up some hits and I think from memory points at a networking issue.

I tried the 40 second reset last night to no avail, the unit was entirely unresponsive. To that extent I successfully removed the drive from the enclosure and will attempt to access the drive via Paragon software later.

I’m still struggling to find an unbricking guide that either still links to the correct img files (most of the older guides appear to have dead links) or some of the later guides appear a little more complex, so I will take some time to try and digest them.