PR4100 remote speed

I have a PR4100 connected directly to a router. A PC is also connected to the router. Transfer speed on local network is fine (~100 Mb/s).

I have 50/50 internet (50 Mbits/s upload and download), confirmed by speedtest and uploads done from the PC to, e.g., Dropbox. However, the download speed when accessing the PR4100 from outside via mycloud.com is somewhere around 200 kB/s (i.e. ~2 MBits/s) from networks with 100 Mbits/s download or more. I know I can’t expect to see 50 Mbits/s downloading files but this seems unreasonably bad.

The router is set to uPnP and the PR4100 cloud configuration to auto. I expect the problem somewhere between the router and PR4100 but I have yet to find it. I would appreciate ideas on things to try. Thanks!

You should try disabling the Media Servers on the Cloud and delete and re-create the Cloud Access account on the device from the My Cloud dashboard. More troubleshooting steps can be found from the link given below.

1 Like

Thanks for the suggestions. All the media servers are already disabled and no 3rd party apps are installed. I’ve also worked through the list in the link already:

  • everything is gigabit LAN (and local network transfer is fine, as stated above)
  • no WIFI, no additional hubs or switches
  • nothing else is on the network. Even if the PC is off the remote access speed stays the same
  • no backup or sync services are running

I will try re-creating the account as you suggested.

Update: I have tried

  • forcing the link speed to 1000
  • re-creating the cloud account and testing different accounts and
  • port-forward 443 and 80 in the router settings (not sure if I would expect a change here but tried anyway).
    No change in the remote speed can be seen.

Is there any documentation on how the WD servers actually handle remote downloads? I thought they simply point towards your MyCloud so the connection can be established, but it feels like the download packages might actually get sent through them as well, reducing speeds.

I will try hosting a VPN on my local network and download from the MyCloud directly through there without going through mycloud.com.

You may try the nextcloud setup, it should give the full network speed… or simply use SFTP.