PR4100 MyCloud Suddenly Not Working

In the past week or so, My Cloud has stopped being able to connect to the internet and therefore can not function. I was using the Auto setting, but I have tried setting up Static with Port Forwarding and have had no luck. I have tried a myriad of setting for the port forwarding as well. Each time router and NAS were rebooted.

This has been running previously for 2 years without incident.

I am running the latest firmware 2.31.204

Update: I was finally able to get the NAS to show MyCloud as connected and I can connect from my network, but can not connect from outside - even if I disable all firewalls between the internet and my NAS.

The issue you are having is the same one that people have been complaining about for over a week. There is nothing you can do; aside from setting up a VPN or enabling direct access to the system dashboard. The phone app for remote and their site are both completely broken right now.

All of Western Digital’s side of the remote access options are broken. Basically your NAS will say that it is connected, but it will not work when you try to access it through the mobile app or in a web browser using It will result in a message saying your device is offline, even though you can clearly see that it is online and connected.

You are lucky if this just started for you. Others, including myself, have not had remote access to their device since March 9th, 2020. Western Digital has stated they are aware of the issues. They said they do not know what the cause is or how long it will be until it is fixed. They have been very shady about what is going on.

Also, they have not updated the status page even though they have admitted their service has been messed up since March 9th, 2020. See here: Disruption

Thanks for all the information. It may have started earlier, I just noticed it when I needed it.

I had not thought of solving this with a VPN, I am now using that as a work around.

I love this NAS, but the support is sometimes slow.

Looks like the issue is fixed. Also, they updated the status page I mentioned.

I can now remotely access the device using the site and phone app. Not sure if it was completely fixed or is just temporarily up. Just thought I would update you.

Thanks. I checked it out and .mine still says offline. Will do some more digging.

I’d say just give it some time and check later today.

Only thing not setup normal on mine is I have the cloud connection set to manual, not auto. Manual requires port forwarding, which I have setup for mine.

Mine was down prior to today.

I was experiencing this issue on my PR2100. I just tried accessing my cloud with wifi off via the My Cloud iOS app, and it did not work (was reporting that Remote Access was Disabled). I logged into the cloud admin dashboard and turned Cloud Access off, then back on and it started working again.