PR4100 - cannot delete folders in a share

Hello - I have a share setup on a PR4100, called vBackup. Within that share are various folders corresponding to dated backups. I need to delete some older ones. I changed permissions on the NAS , admin user, to read/write…it worked for awhile and then I was blocked from deleting folders. Rebooted, latest firmware, etc. What am I missing?

Thank you

I recommended to check and apply the correct permissions via SSH.

I had some issues after using RSYNC to backup my devices with wrong permissions (wrong user, groups, owner).

  1. Log into the NAS with SSH.
  2. Browse to the affected Share/Path (cd /shares/<SHARE>/<PATH>).
  3. Run the command ls -lhA <FILE> with FILE being the affected file or directory.

You can also check multiple/all files by running something like find <ROOT DIRECTORY> -exec ls -lhA {} \; with ROOT DIRECTORY being the directory, where the permissions issues begin.

After determining wrong permissions, run chmod -R 775 <PATH> to fix the permissions and in some cases chown -R <OWNER USERNAME>:<GROUP> <PATH>.

For example if your username is hoemee and you are the owner (standard group name is shares), the commands would like this:

chmod -R 775 <PATH>
chown -R hoemee:shares <PATH>

-R is used to recuresively apply the permissions/ownership to all files in the PATH.

This and the correct settings in the WD Dashboard usually fixes the issue whenever I have permissions problems and can’t delete files/directories.

As a last resort I would just delete the file/directories via SSH but this is risky and you need to be cautious not to remove any other files using the command rm <FILE1> <FILE2> ... or directories with rm -r <PATH1> <PATH2> ....

I hope this helps.

1 Like

Hi John,

Thank you for the reply. I actually opened a ticket with WD and they forwarded something along these lines…but it still didn’t work. What worked was the agent suggested I set up an account on MyCloud with my email address. This worked! I was able to use the MyCloud app on my phone and easily deleted the folders I wanted.