PR2100 admin password wont save/update

After doing a 40 sec reset, the only way I can log in as admin is if I don’t set a password or change the admin account name. If I do either of those things the login screen tells me that I’m using the wrong password/username when I try to log back in. Adding extra users works and I can log in using the added user accounts but not admin, unless I leave the password blank. I’ve tried rebooting the NAS and clearing browser cookies and cache doesn’t help.

I tried a full factory reset, deleting and formatting both drives and it still locks me out upon setting any password to admin. This kinda makes it an expensive paperweight, since I’m not going to keep a device connected to my network that’s not secured at least by a some kind of password.

After setting the admin pass and logging out and trying to log back in

Trying no pass, after setting it, in case it didn’t set

? Anyone have any ideas?

@amicuslupius please check this thread Admin Password login issue

Thanks. The update fixed it