Power Supply failure messages

After relocating my NAS, I powered it up 48 hours ago. I happened to notice blue LEDs flashing nonstop after a couple of hours beyond the power up.
LCD error message: Power supply 1 failed

OK…checked files and file structure via PC network shares…everything was OK. Turned unit off and submitted a trouble ticket, asking if unit under warranty included replacement of power supply.

Received email telling me ticket confirmed but that I needed to access NAS, click on the “?” and select support to provide system logs…powered unit up. Error message: Power supply 2 failed

Anyone have any idea what is happening to this unit? It’s slow as **bleep** but I’ve had no issues with it other than the painfully slow performance.

Hello, welcome to the community.

Have you tried the same power supply on different power plug on the drive? Have you tried connecting the power supply to a different power source?

I believe that this message is an error.  When I had to manually remove power to get my EX4 from an unresponsive state thanks to the new firmware, it then reported the powersupply failure.  In my case, it was confusing the sudden loss of power with a failure.

In answer to your questions:

  1. Yes, I’ve tried both power plug receptacles. When I plugged into PSU #2 after relocating, I got error message that Power Supply #1 failed. When I repowered unit, I plugged into the PSU #1. That produced error message of Power Supply #2 failed.
  2. NO need to try a different power source…unit is power by a brand new TrippLite UPS. It originally was powered by an APS 1000 UPS. I have 3 NAS units [all different brands] that have never seen raw electricity. I am having absolutely NO issues with the QNAP that is also on the same TrippLite UPS.

I’ve seen that message as well. However, there was no ‘sudden loss of power’ that occurred.

I am beginning to think that the firmware upgrade has hosed something within the unit.

And, that is something that WD needs to address ASAP, imo, since there are quite a few issues being reported with the latest version of firmware. I am assuming that I have latest version because updates on the unit are configured to be automatic.


I am having the same problem with the PSU #1 failure. The unit seems to have power, but if you push and hold the power switch the unit says its shutting down and rnever dowes. I have to manually disconnect the plug from the unit.

At the same time I cannot access the unit through the dashboard or any other way.

The panel display says everyhting is good. I have pinged the unit and gotten the address, but when I try to access it through a broser it never connects.

Any suggestions would be helfull.



I wish I could help you, brother.

I was able to access my unit via IP address up until about an hour ago. Now, I can enter password and get absolutely NO response from the unit. Fortunately, I can access files from the WD MyCloud app. Unfortunately, it has no admin tools.

WD is not forthcoming with any information on why their latest update has hosed so many **bleep** devices. They [WD] need to step up to the plate and own this fiasco.

Maybe someone can answer this.

Is the Power Supply Unit internal or are they talking about the external plug in transformer?

Thanks in advance.

Exactly the same issues as of yesterday afternoon. Time machine backup was completed in the morning, then by the afternoon I could not connect to the drive throught the apps or dashboard. The unit is discoverable but will not allow connection through any means.

Message of power supply 1 failure, yet the unit is still powered up.

Solution please WD.


The reference is to internal power supplies. They are similar to power supplies in a desktop or tower although form factor is a bit different.

I replaced one in my Netgear ReadyNAS NV+ a few months ago. Not difficult to do, but, I have no faith in error message that I’m getting since the number of power supply ‘failing’ seems contingent upon which power port you plug into.

I’d also bet the amount of money I made last year that there is absolutely NO WAY that this many people could have power supplies all going out at the same time…and, I made a very respectable amount of money last year.

I’ve been in a “System Rebooting” LCD message mode for the past 4 hours or so…doesn’t take that long to boot one of these even though they move about as fast as molasses. Or, should I say that it SHOULDN’T take this long to reboot. However, I know not what all is involved with a ‘soft reset’…database may have to be rebuilt…I don’t know…going to let it run for another day or so just to see if LEDs stop blinking, and/or, if the LCD message changes.

If you have the EX4, it has dual power supplies. That’s a great feature, IF, you are not getting false error messages…and, I think that my unit is doing exactly that…waiting on a ‘soft reset’ now for around 4 hours. Am going to let it go until this time tomorrow before I pull the plug and start getting obnoxious with WD.

I did not have this problem until the unit updated to latest version of firmware.

Even though this ‘soft reset’ seems to be taking a very long time, I’ve noticed that the HDD LEDs are not behaving like they did on just pulling power cord. Had to do that because unit would not shut down using buttons on front.


In the state you describe, the EX4 won’t power down.  You need to reset the power, I usually just pull the plug out.  As of the new firmware you will likely get a “Power Supply Failure” message which I believe you can safely ignore.


Thank you for your contribution, but, I shouldn’t have to ignore constantly flashing LEDs, or be without admin access to the device.

2ndly, I’ve already been through the basic troubleshooting, level 1 helpdesk options. NOTHING changes the ‘state’ of the device. Regardless of the LCD message, I have the constantly blinking HDD LEDs.

I don’t know a lot about these units, but I’ve almost 15 years of IT experience under my belt. That means that I understand what should be normal and what isn’t when I see it.

I have almost $1000 invested in a device that WD’s firmware hosed.

I have NO admin access. Did I mention that??

Is WD going to replace the unit for me?? I doubt it. And, even if they did, I’d probably lose every **bleep** file that is backed up on the device. As far as potentially lost files, I’m talking a lifetime of photographic memories as a beginning point, ok?

So, this is me; looking around for a place to safely stash 7TB worth of data, without spending more $$$$, and hoping that I can get it all saved in a different location before this unit totally craps out.

This is unacceptable. WD caused this issue with latest version of firmware. As such, THEY need to RESOLVE THE ISSUE. I did not spend $1000 to sit at my desk and be entertained with flashing blue LEDs. Besides, my time is valuable. $800-$1000 per day, to be concise. I don’t need to be wasting time on issues that I did not manufacture.

Addendum: The ‘soft reset’ has been in place now for over 8 hours. Still have blinking HDD LEDs and an LCD message of "System Rebooting’…my only point of access is through Windows Explorer. Thank God it still works.
I’m considering pulling all HDDs, replacing them with fresh HDDs, and hoping once I return the originals, that the file structure remains untouched and unchanged + the unit ‘state’ has returned to normal. 7TB is a lot of data to find space for on a home network…I do not have enough space available on my other two NAS devices to just offload the files, leaving me with this unit as a boat anchor sitting on the shelf.

Sorry to have unloaded, but this is the reality of the situation. I am thankful for everyone’s input and help. Please do not misinterpret that fact. Very grateful, indeed. Just fed up with having to fight a battle that should have never arisen. I have a life away from this stuff. And, I strongly resent being restricted from living it because of trying to resolve this issue.

Like I said, you need to do a power reset.  Make sure you have no USB drives connected to the unit prior to restart. When the unit is restarted, SSH to it and see what is using the CPU.  Then post back here.

Have you just purchased the unit?

Have you enabled media serving across your shares?

Define ‘power reset’…I’ve tried shutting down unit via front buttons…it hangs. Have disconnected power source multiple times…returns to ‘state’ of flashing HDD LEDs [blue] and error message of ‘power supply 1 failed’. Now, depending on which power port is used, the error message may read ‘power supply 2 failed’.

I know nothing about SSH. I am not a Unix [nor any flavor of derivatives] admin, nor a user, other than what is on the NAS unit. I would not have any idea how to go about making the SSH thing happen.

Secondly, there never has been any USB devices connected to this unit. Only connection has been Ethernet cable, routed through a smart switch.

No, unit not just purchased. I’ve had it for a year or so.

Do not recall enabling any media server on it. Getting into it to verify is a hit-or-miss proposition, at best. Sometimes I can access, although painfully slow, via browser and IP address. Most of the time, a ‘timed out’ message appears. Windows Explorer indicates that it cannot connect most of the time, although the device displays in the left-hand pane.

As far as the SSH, I’ll look at it when I can. I have HR Block tax class that is a more pressing priority at the moment. I am also moving files at a whopping 5 MB/s…try that with almost 7TB of data…thought I better try to save the data while I have a connection but it’s gonna be awhile.

1st level support has suggested that I begin the RMA process. However, I’ve email from an individual on 2nd-level support tier wanting me to call.

Again, thank you for your contribution.

Hey, you’re frustrated.  I get it.  This community is here to try to help. If this doesn’t work for you, hit the phones to WD…

By “power cycle” I mean to turn the power off, wait 5 seconds, and turn it back on again.

Turn on SSH in the Utilities panel

Pull up a terminal screen and type

“ssh sshd@your-ip-address”

type your password

when you are connected to the unit, type “top” which will list the processes consuming the most respurces on your EX4.  Look at it for a couple of minutes (it will refresh every 5 seconds), I expect that you’ll find the sme processes in the top slots.

report back here

1 Like

Man, I hate messing with this thing when I should be doing the tax thing but it just bugs me that it isn’t working correctly. I am sooo far behind in that class.

Anyway, got the SSH protocol setup and accessed the device. I did a screen print but don’t see anywhere or way to attach to this thread. The primary process taking up 80%, or more, of CPU slice time is listed as:

smbd -D.

CPU usage varies anywhere from 65% to 89%…on the above-listed process.
****************05:10 hrs
Also stopped file transfer. It hung somewhere around 3.5 MB/sec after 16 hours…restarted transfer using Lenovo PC/Win 8.1 as intermediary between the EX4 and QNAP, with smaller total file size. Transfer rate running between 45MB/sec to 70 MB/sec. Dropped transfer size from 6.7TB to 2.2TB. Will manually control what moves and when instead of moving everything at once. This ‘chunk’ estimated to be completed around 3pm today.

Found a directory on EX4 that I do not remember putting there as a share. The directory name is Smartware and seems to be a backup of a 3rd PC [not the one I usually am on, or the one I am using to currently transfer files] on the network. I’m wondering if the smbd process is related. Found threads with similar issue and it appears the consensus was that it was the Smartware application causing the issue. I’ll have to move over to the 3rd PC to see exactly what is going on as far as a backup is concerned [one of the sub-dirs shows a date of today, 10-09-2015].
***********************0750 hrs
Backup target on the 3rd PC was not connected so not sure how the Smartware directory was updated with a date of today, but, it was. Redirected that backup to different NAS. Admin access via web browser worked much faster on our 2 Win 8x machines, after I repowered the unit. I think that is a small victory but unsustainable. Eventually, the connection will be lost if everything holds true to experiences this past week.
So, I have absolutely no clue as to what the Samba thing is doing, or if it is remotely associated with the SmartWare software because the HDD LEDs are still blinking steadily. Sometimes there is a variation in pattern, but predominantly all in unison at 2, maybe 3 times per second.

ok, smbd is the samba daemon (file sharing) so this indicates that the unit is busy serving files.  that is normal behaviour if the unit is doing just that. if you look at the “top” report, see what the % in io state is, also the % in sys.

I’m no expert but I think I may have found a reason for the issues I’ve been having. And, no…there were no processes running on the EX4 that would be ‘serving files’.

Awakened today to find that one of a multitude of file transfers that I initiated to ‘save’ my wazoo, had again failed to complete. Only this time, it was way different.

One of my NAS devices was not accessible via browser, nor were some of the shares. Started troubleshooting after I talked myself away from throwing things through the windows and looking for a baseball bat to finish the job.

NAS IP address had been changed. Mind you, it originally had a static, NAT IP but now had an IP of and a subnet of I checked it out on Whois and apparently that is a local-linked IP address. Have no clue what that means other than it is local and not external. I can live with that. I just don’t know why or how the IP address was changed, AND, it caused me another level of frustration because I had to re-configure the NAS back to the NAT IP and subnet just to be able to access it.

Further investigation yielded that NONE of my NAS devices were accessible. They all reside on a common switch. So, I start looking at switches. The link from main switch is down. Weird…no reason for it to be down. Start checking ports…have lost 3 ports on main switch. I finally get into it and find that these ports were placed in a ‘disabled’ status under a heading of Admin Mode…I have no reason or logic to explain this. I was asleep when this happened.

However, it would appear that something went amuck on the main switch. It is going back to Netgear since I cannot get it to take a firmware flash, either. And, I can’t have a switch complicating issues for me. I fight enough of the ones I create on my own. Changed the ‘bad’ switch port configuration of those 3 ports back to ‘enabled’…they now work as they should.

So, at this conjecture, I’m thinking the EX4 firmware update came through at about the same time I installed the switch that I’ve discovered over the past week is a problem child [unable to flash a firmware update]. It has been replaced with an identical switch. We’ll see how things go.

In that I am not completely sure of what transpired on the ports being disabled, I can only guess that maybe there is a hardware issue happening on that switch. I have replaced it with a different one and all seems to be well at this time. NO flashing HDD LEDS when the EX4 is in idle mode [having no processes running such as file transfers, etc.].

Thank you all for your input and patience. I’m 62 years old tomorrow and have been losing patience with nonsense like this the older I get…my apologies.

What firmware version where you guys using? Was it 2.10.302? Or was it 2.10.310?

I literally had the same issue and had WD send me a new power brick and it seems to have fixed my issue. So im trying to determine if its just coincidence that I got this message and it was an actual failure, or if firmware was the cause.