Power Outtage, DX4000 stuck on "repairing"

We had 3 power outtages in the span of 30 minutes last Saturday

The Sentinel was hooked up to a UPS but the UPS evidently failed…I believe the Sentinel was in the middle of performing a “Verifying Data” check during the 3rd power outtage - which in turn corrupted the OS/Drive for lack of a better term.

Anyhow, early Monday morning the Sentinel was stuck on the “Loading OS” message for hours and hours, but finally loaded it up and changed message to “Repairing” around noon, and fortunately I can see the data and shares still there from my office PC.

The problem now is, it has been stuck on “Repairing 32.13%” for the last 6 hours.

The data is still accessible and I am in the process of backing it up now, but it is very very slow.

I am uncertain if I should perform a recovery of the Sentinel after I back up my data, or if I should just let it sit here on repair that is stuck on 32%?

I should note that I don’t have RDP access to the Sentinel either, as I accidentally turned off remote access earlier in the Spring (like a dope!)

Thanks for any help!

A repair process takes days. Leave it for another day then assess

after you get the data backed or and after you have waited or got tired of waiting, press the power button briefly once and it should do a clean shut down.

Power it back up and see if the status changed.

You prob need to do a recovery to get RDP back anyway

thanks for the replies everyone.

i’ve been backing up files through windows explorer to another NAS on the network, slow going, should be done in another day.

still no change on the LCD panel on the Sentinel - says Repairing 32.13% - been that way since early this morning and it is now almost early evening. obviously can’t tell if it is hung up, or actually doing something, very frustrating.

but, it’s letting me copy files so it could have been a lot worse.

I will need to do a recovery - which I’ve not done and am dreading…Curious if it will let me do it even after potentially interrupting the ‘Repair’ process that is going on now.

Would hate to go through the recovery only to find out it will go in Repair mode again…

if it is rebuilding the array doing a recovery will not magically fix the array unless you decide to delete all the information

Well, it’s now Wednesday morning, and the Sentinel LCD still says “Repairing 32.13%”

However, on the plus side I noticed that it is letting me browse and copy files notably faster than on Monday & Tuesday.

I still have about a day’s worth of copying left to our other NAS (which is just a 6 TB WD MyCloud).

We purchased a new UPS, but I am hesitant to power off while seeing the “Repairing” message - and since I have no RDP access I’m going to have to power it down via the button on the front

At this point I am unsure as to how to proceed with the Sentinel. I would like to continue to use it if possible.

You could shut down with a briefpress of the power button… Then connect your UPS and power up. This may sort it out.

Just an update here:

Finally finished backing up all of the Sentinel data to our spare NAS with no problems. Slow, but fantastic not have lost anything.

Got impatient and wanted to get the new UPS installed, so I powered the Sentinel down with the front button, and it appeared to have shut down gracefully.

Installed the new UPS, powered up the Sentinel and can see all shares, and most importantly - no LCD message about “Repairing 32.13%” Great to have a full 3TB copy of the Sentinel data on that extra NAS too.

Lesson learned - always check status of UPS units - I got very lucky on this one.

Only thing remaining now, is doing an OS recovery on the Sentinel so I can get RDP access again :triumph:

Anyhow, thanks @ceaxer and as always @Gramps for the replies here…Am sure I’ll need some pointers when it comes to running the recovery (which sounds like a nightmare for some)

Glad to hear that this worked out