Power lost while updating what do i do now

my wd tv live medie player was up dating to the latest files whe the power was lost  when i got power back my wd tv box now says to install USB with firmware . tryed it but never work wrong firmware i guess. i tryed formatting the usb to fat 32 and only used the files bin, ver, and fff. but still not reading  it. not sure if i got the right files. p/n: wdbhg70000nbk-12 where do i get the files to start from the begining. also tryed factory reset.what can i do now?


ok tried that and it never work. any other ideas. Thank you

Download the Firmware and unzip it to the root of a FAT32 formatted USB stick. There should be no folders, only these 5 files.






Now open the “wdtvlivegen3.ver” file in Notepad (or any text editor) and you will see this …

VERSION=‘2.01.86’         <--------------------------- Edit this

Change  VERSION='2.01.86’  to   VERSION=3.01.86’  this will trick the player into thinking it’s New Firmware and should prompt to Update the firmware. (again)

ok done that still nothing . do i surpose to keep all the 5 files on my usb or just the  ver. fff. and bin. i read where it said only 3 files should be on the usb.

*you do have “Auto Detect New Firmware” enabled in your Settings" ? *

You could try  Rollback Firmware


failing that … i’m outta ideas

Maybe try contacting WD Support ?


the only thing i am getting on my wd tv live is : insert a USB drive with firmware to recover your WDTV : in multiply languages.  the usb  blinks when i put it in the wdtv. but not sure if it is reading them.

Do i have to start from the beginning and add all the files  not the updates but the install the entire program again. if so where can i get the full program files.

i can get in to the settings to see what on there . and the only thing i can do with the remote is turn the box of and on…

Try an earlier version of firmware:


If it’s not recognizing the firmware having tried multiple thumb drives (with FAT32 format), then you’ll have to call support; your device is not going to recover.

WOW it is actually upgrading says loading firmware.

thank you .

Yeah, Actually Joey said it first.   :laughing:

This is good information to save in the ol’ “information bank”.  Thanks guys for your knowledge.