Power Glitch Disconnections - My Book Essential 2 TB


#1

Hi all,

I recently purchased the subjected (model WDBAAF0020HBK) and all has been going fine. It is mainily used to watch and playback my media on the PS3.

I noticed that very randomly and infrequently - although extremely frustratingly - the drive would disconnect. Educated guesses and initial assessments pointed to possible power, but could not really put my finger on it. At the time of the disconnects, I could make out a vague clicking like noise. Other posts have suggested that this was either a faulty drive or lack of power getting to it…

I also thought it may be the PS3 not providing the drive with enough power as I never experienced such issue on my 1TB drive and thought that 2TB may require more power.

After researching on here, I did find a few other community users experiencing similar problems - for example:-

http://community.wdc.com/t5/My-Book-for-PC/MyBook-2TB-seems-to-be-regularly-restarting/m-p/78570/highlight/true#M3186

http://community.wdc.com/t5/External-Drives-for-Mac/MyBook-Studio-Studio-Edition-II-2TB-keeps-disconnecting/m-p/20495#M785

By chance yesterday I came across the WD announcement and new firmware. I was so happy to see the release notes, which seems to point that it is actually a WD fault that was causing my issue:

"Firmware 2.018/2.019:  This firmware update fixes the drive’s handling"

It also seems that this was not the only drive affected.

 

Has anybody else experienced such issues and more importantly, tried the new firmware updates? Any joys?

Thank you…


#2

This firmware update does not seem to have fixed my issue of the drive’s handling of infrequent power glitches which can cause data access issues.

I was playing back media content and the drive cut out.


#3

Do you have the same issue when using your drive on a PC?  Also, does it pass all three of SmartWare’s diagnostics?


#4

I don’t really use the drive as much with a PC as it’s mainly used for playing back media from playback devices.

Despite the firmware update, I still get the infrequent power glitch. I don’t think this is inherent within the drive as the firmware release notes for 2.018 states it specifically addresses this which means WD must know of the issue.

Prior to the firmware update, the drive does pass all of the checks on the Smartware suite.

I tried an RMA, got myself a new drive and transferred all my files over and still have the issue. It has to be with the smartware as I have two 1TB (My Book Essential Edition 2.0) without WD SmartWare and have never ever experience such an issue.


#5

did you found the problem and fixed it?  How do you removed the WD Smartware from the drive…just deleting? do you removed from PC too? Thanks


#6

No joy and no solution.

I’ve been in contact with WD and are going to receive another replacement, but this time it’s going to be a Essential Edition or Elements as I don’t want any firmware.

I strongly believe the firmware is causing the power glitches!


#7

It might also be some of the green technology they incorporated into drivers. It it doesn’t detect enough activity it goes to sleep. I saw this in a post about Elements http://community.wdc.com/t5/Other-Externals/WD-Elements-SE-2-5-quot-1Tb-Change-Spin-down-Time/m-p/70350#M1029  and http://reviewstash.com/viewtopic.php?id=1524

Joe 


#8

Im having the same problems with that same drive.  I have 2 of them and they both disconnect very frequently.  I can not run the diagnostics on it because it disconnects so frequently.

I have tried plugging it into a powered USB hub in case it was a power issue, but got the same results.

Also I have tried it on 4 different PC’s and 2 notebooks with the same results.