Post firmware update problems WD Mycloud

After Upgrading mycloud to latest firmware i am now unable to log into the dashboard, i can browse the shares and access the twonky page but that’s about it, there are a lot of articles about this but so far no solutions, any advice would be appreciated.

Did you by chance unbrick your My Cloud at some point in the past? If so the inability to access the Dashboard after upgrading from v3.x to v4.x firmware has happened to some.

Otherwise try doing a 4 second reset and if that doesn’t work, a 40 second restore.

I would suggest checking the allocated address give by your Dashboard ( Right click shortcut and Properties/ Web Doc ) I allocate a set IP ADDRESS for my devices to help troubleshooting this kind of thing. Reset requires password assignment again etc.

I’m having the same issue. I can access the drive and shares via Windows Explorer but when I access using a URL nothing happens. Actually, if I put in a bad password, I get a response that the user name and password is incorrect. I’ve had it for a couple weeks. It worked great out of the box. I upgraded the firmware and I connect a WD My Passport Ultra. Nothing but issues since. I did one reset and still issues. The only thing that may be odd is with my reset I was expecting the NAS to reset to admin with no password but my old user id still works.

I have not un-bricked my device in the past, I have also tried the reset process but that didn’t work either, the IP address info is correct, it has a reservation so wont change.