Possible solution to playing mkv/mp4 videos with the WD TV Live 2


I’ve recently bought a WD Tv Live 2 and had trouble at first getting it to play some of my files.

The files that the device refused to play were all mkv and mp4.

Sometimes I would only have sound, sometimes I would get a black screen for a couple of seconds than the device would display the video directory listing.

All these tries were done from a media server (UPNP) over the network.

Then I discovered that a file that wouldn’t play over the network would just play fine from a USB stick plugged into the TV Live.

Suspecting something fishy with UPNP, I tried accessing my videos from my server with NFS (aka Linux shares) instead of UPNP. And bingo! The TV live worked flawlessly, eating everything I threw at it! :smileyvery-happy:

So I don’t know if it was a problem specific to my UPNP server (UShare) or if it’s an issue globally with UPNP, but if you have trouble playing some videos, it could be worth it to try playing it from an usb stick or from windows/linux shares.

Hope that helps :flushed:

1 Like

Thanks for sharing your experience, very helpful.