POSSIBLE SOLUTION: Spinning Arrow of Death while Streaming from Media Server

All -

Like many of you, I have been fighting with the the SAoD for quite some time.  I’ve been running WDTVs for a few years, but it just started happening about 6 months ago.

My library is all MKV files.  DVDs are converted via Handbrake.  BDs are bit perfect rips via PavTube.

I tried everything I could find in the forums, and nothing worked.  I also tried different media servers including Serviio, PS3 Media Server, and Universal Media Server. 

In trying to get streaming working via my Xbox, I ended up installing tversity, AND EVERYTHING WORKED!  Since there is no “free to try” option, I hadn’t used it before.  At first, I had all the files transcoding, because I figured the WDTV would lock up, same as before.  But then, I set tversity to never transcode, and I could not lock up the WDTV (Which used to happen on the 2nd or third file I opened).

My setup is a Windows box hosting some files and pointing to a NAS for others.

This is what I did (not sure how critial any of these steps are.  Just letting you know what worked for me).

  • Uninstalled all other media servers.
  • Uninstalled all CODEC packs.
  • Ran “ccleaner” in Windows and used the “Cleaner” and “Registry” tools.  Run them multiple times, sometimes things stick.
  • Reboot
  • Installed K-Lite “full” CODEC pak with default options.  (Careful not to install the crapware).
  • Installed tversity.
  • Pointed tversity to my media files.
  • Configured tversity --> settings --> Never Transcode
  • Connected to media server via WDTV and started watching content!

I understand that everyone has a different setup, but this worked for me.  I’m not sure what is different about tversity from the other media servers I had used, but so far, it is working great.

Also, I should mention that all my devices are wired ethernet, so full bitrate streaming is not a problem.  If you are connecting over Wi-Fi, you may have better success with transcoding the movies.

Good Luck!

Hello,

Thank you for sharing your experience.