Possible issue with Live Hub and the new 3TB 3.0 USB drives

Not sure if it is one or the other or a combination of the two.  I have purchased the 3TB drive and had the same problem.  After transferring my whole library from a 2TB and 1TB drives to the 3TB I plugged it into the WDTV Live and it scanned and played the movies.  The next day I went to continue a movie I was watching and it gave me the same error stating that it didn’t recognize the format.  I tried to play move I previously played and got the same message.  A couple of the folders did work but about 3/4ths of the drive are now listed as corrupted and will not play.  I plugged the drive up to my Win 7 PC and it states 1.43GB free of 746 and in the red.  When I go into the folders of the files that will not play the files state that the size of the files are listed as 0KB and will not play stating that the files are corrupted and can’t be played.  So I formatted the drive and started the process all over again and it worked for a few days then guess what happened.  THE EXACT SAME THING AGAIN!  All files listed as 0KB, corrupted, and won’t play.  So is it the combination of the WDTV and the new 3TB drives that there is an issue or is it only one of them?  I am heading back to Best Buy to exchange the drive and see what happens.  If this happens again then I know there is a major issue with the combination of the WDTV Live Hub and the 3TB drives.


You should have ready the previous posts that discuss this exactly.

Basically, it seems 3 TB WD hard drives are not compatible with the hub. I’ve learned this the hard way as I also lost 75% of my data.