Portforwarding to WD My Cloud not working

Hello.

I think I’ve really tried everything. But I can’t get my port forwarding to my WD My Cloud working - no matter what service or port am trying.

My goal is to access NZBGet and ssh over the internet.
I’ve got a FritzBox 7490 and port forwarding obviously enabled. I’ve tried different ports and setup. For testing purpose I’ve also forwarded port 80 to access the dashboard. That doesn’t work either. I even tried exposed host, but didn’t work as well.

Tbh I have absolutely no idea how to access my NAS from the internet and I’m about to give up…

It feeld like My Cloud has some sort of firewall blocking every access not coming from my local network.

Port forwarding in general does work. To test his I installed an apacheserver on my PC, forwarded port 80 and checked with the public ip - which was working fine. Also accessing my FritzBox over the internet is working fine.

It’s just WD My Cloud I can’t get to work :frowning:

The really weired part is, that I’ve had it working once. I was enabling cloud access (what I actually do not want to use), restarted my NAS and afterwards it was working. I’ve disabled cloud access and it wasn’t working anymore. But when I now enable cloud access it still won’t work :slightly_smiling:

Maybe someone has an idea. I’m starting to get mad because of that :frowning:

Thanks and regards,
André

Oh my god… I finally got it working…
I have no idea why, but it is working!

What I did:
Settings -> General -> Enable Cloud access
Configure -> Manual -> I’ve left the default ports (for the moment)
On my router I’ve enabled port forwarding to WD My Cloud

Now it still wasn’t working! I’ve rebooted my NAS and while it was booting I was using a port scanner to check open ports.
Finally port 80 was open! I’ve tried to open the page and got redirected to the UI subdirectory with the message “No Access” - but I didn’t really care.
The weired part is now, 1 minute later that port was closed again.

So I’ve accessed the dasboard and went to cloud access.
I clicked on admin (the only user I’ve got) and und “Cloud devices for admin” I clicked on “Get Code” (for 48 hrs)

Port scan -> Port 80 open. Created another port forwarding to nzbget -> open!

Delete the code and so far it’s still working :slight_smile:

-edit-
Next problem: Now my VPN doesn’t work anymore :frowning:
The weired thing again is, that I’ve disabled VPN before aswell to check if my problem was maybe related to that configuration, but even without VPN it wasn’t working.

Hello, unfortunately I have no idea that could help, hopefully another user will be able to chime in.