Port Forwarding issues

Short story:
My Cloud Ex2 Ultra
Apple Time Capsule router
Trying to set up remote server
Enabled ssh with password
enabled “remote server” with password
added port for remote backup 873
added port for ssh 22
when I click on “details” for each port forwarding type, the pop-up says “checking” then says “fail”

Long story:
I went to portchecktool.com and tried port 873 and 22. Both failed. Went into my airport router and manually set up port forwarding for those, even though NAT-PMP was enabled. Now portchecktool.com can see those open ports.
I went back to my Ex2, rebooted it for good measure, and clicked on details again. I still get the “fail” message.
I have a Qnap NAS that I’d like to rsync backup from one to the other. For kicks, I go to my Qnap and try to set up rsync. I can see the Ex2 but a test button during the setup shows an error message about the port not being open.

I’ve also tried many times to rsync the other direction. In my Ex2 Backup section under “remote backups” I’ve not been successful to see the remote NAS (my Qnap) directory list.

Has anyone seen a port forwarding issue on an Ex2 and an Apple router?

Hello,

When you try to do a remote backup from the dashboard it will do it only to another my cloud device, perhaps you can try a different way to do this other than from the dashboard. Let’s see if another user can share some information or tips on this matter. If you see the following link it might help you more with how remote backups works:

I have a similar setup and recently was setting up something similar. After days of issues, I finally figured it out!

Question: What exactly are you trying to do with the “remote server”?

Is it for streaming media away from home network, or mainly for transfering files to/from MyCloud outside of your network? Or something else?

My goal was to setup remote access so I could stream the MyCloud’s media library directly to my media player (Infuse, VLC) outside of my hone network. However, my setup does also works well with managing files / folders remotely.

Let me know if you still need some help…