Port forwarding failed to connect on port 80 and port 443

I am very familiar with Port Forwarding as I have several wireless cameras setup with Port Forwarding on my Asus router and they are working just fine.

Can someone please provide instructions on how to get rid of this error message from  Cloud Access. I have NOT configured any Port Forwarding for WDCloud for Cloud Access. I have turned on FTP access with WDCloud and this is working without any issues. I have several cameras sending motion detected images to different folders on MYCloud and there are no issues with the uploading of those images to my NAS.

I also have a Nexus 7 and an Android phone that has the WDCloud APP  installed. I can access the folders in question from these devices. So why am I getting the error message above and how do I configure Port Forwarding for Cloud Access?

You need to forward the http port and the https port. For example, i have an Asus router and have assigned a fixed IP address to the NAS. I have forwared the external 8080 and 8443 ports to the NAS in the router.

After having done that, I have setup the network config on the NAS through the admin interface.

After completing this, the NAS would typically let me know the port forwarding was failing.

I found that restarting the NAS was solving this issue.

I am interested in your camera set up. Would you please share which cameras you are using? Are the cameras uploading video sequences or only snapshots to the ftp?

I am using several Foscam 8910 cameras. I have each camera setup under my user name as follow:

The folders below must be created on your MyCloud before setting up the cameras. Use any naming convention that please you. However for the Foscam I believe it looks for a “snap” folder.




In the FTP configuration I have the following setup in the Foscam Gui:

FTP Server: 10.xxx.xxx.xxx (MyCloud IP Address)

FTP Port: 21

FTP User: MyCloud User Name

FTP Password: MyCloud Password

FTP Upload Folder: //Myname/Camera1/snap (please note the 2 forward slashes at the beginning of the path)


Submit changes and then Test.

I also updated my Alarm Settings to:

Motion Detected: On

Send Mail on Alarm: On

Upload Image on Alarm: On

Upload Interval In Seconds: 1 second

Scheduler: Select an individual schedule per camera

I tried the reboot option and have the same error message.

Connected (Relay connection established)

Port forwarding failed to connect on port 8080 and port 8443.

I’m perplexed by what you’re saying.   Port forwarding should not be needed at all for your cameras, since they’re on the same network as your NAS and thus won’t be crossing your router boundary.

I’m not using port forwarding with my NAS. I’m using it with my cameras because I don’t want to use the default port of 80. I’m also using no-ip’s ddns so I can get to my cameras from the Net when I’m on the road.

I’m only exploring the Port Forwarding issue with the NAS as it’s providing with an error message whether I have port forwarding setup on my router or NOT. It appears that one has to go through WD 's servers to authenticate with your own NAS, if you don’t have port forwarding setup on your own router. There is something not setup properly in the NAS  software with respect to port fowarding as the error occurs if I have 80 and 443 as the default ports and NO port forwarding setup on my router for the NAS.

Your remote clients and the NAS must access WD’s servers whether you’re using port forwarding or not.

WD does its own dynamic DNS in order to find your NAS using a wd2go.com hostname, so your NAS must communicate with WD’s servers any time your address changes.

There’s basically two ways to set it up – you let the NAS pick the ports, and it uses UPnP with your router to establish port forwarding.   Not recommended if you’re already using those ports NOT via UPnP for other reasons, and if your router allows re-use of ports. 

Or, you must set up MANUAL port forwarding on BOTH the NAS and the router.

Which option are you trying to do?

See if this gets you anywhere:


Tony I followed the steps exactly in your message and have the same results. I have opened up a ticket with WD.