Port forwarding connection not working

I am trying to get the port forwarding to work for my connection from WAN to MCM.

This is what I have currently set up.

I have DD-WRT loaded on ASUS 68-U router. In the router, I have forwarded ports 3333 to 80 (HTTP), 4444 to 443 (HTTPS), 4443 to 4443 and 8080 to 8080 (both related to WEBDAV) to my MCM device (static ip allocated from the router and verified that MCM has the correct IP)

On MCM dashboard, under “Settings/General/Cloud Access”, Cloud Access is turned ON. Next to that, there is a “Configure” button. I have set that to “Manual”. For “External Port 1 (HTTP)”, I have put 3333 and for "External Port 2 (HTTPS), I have put 4444.

I have not configured the section in “Settings/Network/Port Forwarding”. Do I need to change the ports 80 and 443 to 3333 and 4444 respectively? I actually don’t  understand the meaning of this port forwarding in MCM itself as I am forwarding the correct ports in the router.

Also, I have a WD2GO login setup and my IPhone is setup with a validation code.

I have tried different ports, rebooting MCM and my router, made sure that my external ports 3333 and 4444 are open from the WAN side… BUT, MCM only does a relay connection. I cannot get port forwarding connection to work. It will always establish a relay connection. Any help would be very appreciated. Thank you.

EDIT: I have disabled UPnP on my router.

Is this problem solved? I wonder if this is related to my issue.


I am on the latest firmware 1.05.30

Hello and welcome to the community,

I recommend you contact support directly for assistance with this.

Contact WD