Pop Up Screen asking for user name and password

I have several issues.  But let me asked them one by one.   I created a “shares” ; Private  and checked JoAnna with full access to the “shares” from the Dashboard.  The share has a little lock on it.    When I access this specific “shares” (forbusinessonly) from my computer, a pop up window appears; I put in my user name and password, and it never connects. It just sits there. . . .    I used the admin user and my user JoAnna - same result with both.  I also tried to log in with the user name to get here; nothing works.

Can someone send me what the system (WD) believes is my user name? 

The second questions I asked last night, but I don’t think I described my situation well enought.  I have a website in which I want to provide a link (public) for all the world to see and access these documents with ease, or in other words without passwords or a time delay; is this possible? 

I am open to a phone call. . . . .   thank you.

Try disconnecting any other private share that you might have mapped. You can share public links with the WD2go app.