Poor RAID 0 (and 5) performance on WD Red drives

Hi all.

I’ve purchased 3 WD Red drives to use in a file server I’m building, initially planning to use them in RAID 5, but after very poor performance I’ve tried 2 of them in RAID 0, with better, but still poor results.

It’s running on a motherboard with an Intel C206 chipset, Xeon processor and 8GB RAM. Operating System is Windows Server 2012, and all drivers including Intel Rapid Storage Technology have been installed.

After initially setting up the 3 drives in RAID 5, I noticed that performance of the computer was very bad and decided to run a benchmark from the Command line by typing:

winsat disk -drive c

The results were extremely bad: 4MB/s seq read, 1MB/s seq write!

I then wiped and reconfigured the system so that it had 2 drives in RAID 0, plus one stand alone drive (with plans to buy a 4th drive and set it up in RAID 10), and ran the same benchmark. While a big improvement, I am still experiencing particularly poor read results from the RAID 0 array, worse than those from a standalone drive (although the write speeds seem normal):

RAID 0 Results:

Random Read: 2.06 MB/s
Sequential Read: 40.68 MB/s
Sequential Write: 290.66 MB/s

Standalone Drive Results:

Random Read: 3.42 MB/s
Sequential Read: 70.94 MB/s (even this is poor compared to the 110MB/s+ that I get on my single consumer grade Samsung 1TB drive?)
Sequential Write: 150.32 MB/s

A look online indicates that the 4K sector size may have something to do with the problem, although I have been unable to find anything that tells you how to go about rectifying this issue?

I’d much appreciate any advise.

Many Thanks


Have you tried testing the drive individually?

Or have you tried the drives on a NAS enclosure? I mean these units comes ready to be use on NAS enclosure and they don’t request anything to be change.

I’ve taken the drives out of RAID and tried them all individually. All 3 achieved around the same results - 68MB/s read, 140MB/s write.

I’m not intending to use them in an actual NAS enclosure, but keep them in a Windows file server. I thought that their optimisations for use in a NAS enclousure would have made them particularly suitable for my needs too? Is it normal for them to perform poorly in a desktop / server?

I have the same problems when trying to set my 4 3TB Red drives in RAID 5.

Initially I tried connecting them to my Adaptec 3805 controller but several of the drives kept disconnecting (I suspect this was an issue with the controller firmware), and then connected the drives directly to my Asus Maximus Extreme-Z motherboard.

When set up in RAID 5 the write speeds are abysmal, regardless if I have the RAID array set up with Intel RST or in Windows Server 2012.

I have another 5 3TB Red drives in a modified Qnap TS-509 Pro with RAID 5 without any performance issues, so I suspeced one of the drives was misbehaving, and I ran DLG diagnostics on all drives in case there was an issue, but all the drives were fine there. 

Since I couldn’t get RAID 5 usable in my computer I decided to test RAID 10, and the performance there is flawless so I am now running them in that configuration configured with Intel RST 11.7.

I know Intel RST doesn’t officially support Windows Server 2012 but I have another machine running 3x 2TB drives in RAID 5 without any problems on the same software plattform, so I don’t really think that is an issue (the fact that I had similar issues with the array configured in Windows Server support this conclusion).

When I called WD Support to see if they had any ideas they basically just told me to buy RE4 drives for RAID in a computer… I prefer the low noise, temprature and price of WD Red drives over the RE4 drives, so I guess the ones I have in my computer will stay in RAID 10.