Poor operation of WD Utilities under WiFi (WD Quick View, WD Smartware and WD Link)

Basic problems:

  1.  WD Link NEVER detects my MBL when PC is connected via WiFi to router, but works fine if use wired connection to router instead.

  2. WD Quick View & WD Smartware only seem to partly work when connected via WiFi to router, but work reliably and well if use wired connection to router. (WD Quick View and WD Smartware typically see the MBL after accessing the MBL via Windows Explorer; % Used only seems to get updated when connected via wired connection).

  3. If using a WiFi Range extender, neither utilities seem to see MBL.

HOWEVER, access to the drive is totally functional in every other way (even with Range Extender)  … Windows Explorer has full access via shared name or logical mapping; Dashboard is fully functional via web browser; Wd2Go utilities all operate perfectly for remote access; Twonky server functionality works well allowing DNLA functionality from remote players.

Expanding a bit: I have emailed WD support directly on these issues and although they have been helpful, I don’t have a resolution yet. I accept the problems don’t stop the MBL being used, but I feel I’d like to understand why they don’t work as a minimum!

It may be useful to know that my router is a Virgin Media Super Hub (Netgear). I have updated firmware on MBL to latest.  I am using the latest version of all tools. I tried a factory reset as well! I have tried disabling all firewalls, locally and on the router. I have tried it from a desktop PC and a laptop – symptoms identical. My MBL has a static IP (assigned via reserved entry in DHCP reservation list in router, but I have also tried setting static IP directly in MBL).

Anyone got the same symptoms? Anyone know how the utilities detect the presence of a MBL? Anyone know why it works wired, but not wirelessly? Anyone get any suggestions?

Finally, sorry for the long post!