PLZ Help me with mkv


#1

I  Have wd TV it’s work OK but I have new mkv file it can’t play and it’s hang with the rest of files. PLZ can you advise me step by step.

Thanks a lot.


#2

Check for compression. Use MKVINFO to find a line whether the merge was compressed or not. If it was, you can extract it and remerge, but remember to turn off compression.


#3

see here:

http://community.wdc.com/t5/General-Discussions/WDTV-Live-not-play-MKV-or-video-file-at-all-solution/m-p/53304/highlight/true#M12791


#4

I just tried all the above the movie start but it hung on the beginning…


#5

Have you reset your WDTV before playing the new MKV.


#6

Yes of course.


#7

Post the mediainfo of the ‘bad’ file.


#8

(MKVInfo) + EBML head
(MKVInfo) |+ EBML version: 1
(MKVInfo) |+ EBML read version: 1
(MKVInfo) |+ EBML maximum ID length: 4
(MKVInfo) |+ EBML maximum size length: 8
(MKVInfo) |+ Doc type: matroska
(MKVInfo) |+ Doc type version: 2
(MKVInfo) |+ Doc type read version: 2
(MKVInfo) + Segment, size 7060115593
(MKVInfo) |+ Seek head
(MKVInfo) | + Seek entry
(MKVInfo) |  + Seek ID: 0x15 0x49 0xa9 0x66 (KaxInfo)
(MKVInfo) |  + Seek position: 4099
(MKVInfo) | + Seek entry
(MKVInfo) |  + Seek ID: 0x16 0x54 0xae 0x6b (KaxTracks)
(MKVInfo) |  + Seek position: 4262
(MKVInfo) | + Seek entry
(MKVInfo) |  + Seek ID: 0x1c 0x53 0xbb 0x6b (KaxCues)
(MKVInfo) |  + Seek position: 7059965913
(MKVInfo) |+ EbmlVoid (size: 4043)
(MKVInfo) |+ Segment information
(MKVInfo) | + Timecode scale: 1000000
(MKVInfo) | + Muxing application: libebml v1.0.0 + libmatroska v1.0.0
(MKVInfo) | + Writing application: mkvmerge v4.3.0 (‘Escape from the Island’) built on Sep  5 2010 10:30:51
(MKVInfo) | + Duration: 6207.201s (01:43:27.201)
(MKVInfo) | + Date: Thu Sep 09 23:20:19 2010 UTC
(MKVInfo) | + Segment UID: 0x98 0x8c 0xf7 0xd5 0xa7 0xb6 0x71 0x92 0x99 0x46 0xc9 0x3d 0xed 0xbc 0x7c 0xef
(MKVInfo) |+ Segment tracks
(MKVInfo) | + A track
(MKVInfo) |  + Track number: 1
(MKVInfo) |  + Track UID: 1636874124
(MKVInfo) |  + Track type: video
(MKVInfo) |  + Lacing flag: 0
(MKVInfo) |  + MinCache: 1
(MKVInfo) |  + Codec ID: V_MPEG4/ISO/AVC
(MKVInfo) |  + CodecPrivate, length 56 (h.264 profile: High @L4.1)
(MKVInfo) |  + Default duration: 41.708ms (23.976 fps for a video track)
(MKVInfo) |  + Name: The Expendables
(MKVInfo) |  + Video track
(MKVInfo) |   + Pixel width: 1280
(MKVInfo) |   + Pixel height: 544
(MKVInfo) |   + Display width: 1280
(MKVInfo) |   + Display height: 544
(MKVInfo) |  + Content encodings
(MKVInfo) |   + Content encoding
(MKVInfo) |    + Content compression
(MKVInfo) |     + Algorithm: 3 (header removal)
(MKVInfo) |     + Settings: length 1, data:  0x00
(MKVInfo) | + A track
(MKVInfo) |  + Track number: 2
(MKVInfo) |  + Track UID: 1954314154
(MKVInfo) |  + Track type: audio
(MKVInfo) |  + Codec ID: A_AC3
(MKVInfo) |  + Default duration: 32.000ms (31.250 fps for a video track)
(MKVInfo) |  + Name: English AC3 5.1 @630Kbps
(MKVInfo) |  + Audio track
(MKVInfo) |   + Sampling frequency: 48000
(MKVInfo) |   + Channels: 6
(MKVInfo) |  + Content encodings
(MKVInfo) |   + Content encoding
(MKVInfo) |    + Content compression
(MKVInfo) |     + Algorithm: 3 (header removal)
(MKVInfo) |     + Settings: length 2, data:  0x0b 0x77
(MKVInfo) | + A track
(MKVInfo) |  + Track number: 3
(MKVInfo) |  + Track UID: 12818590
(MKVInfo) |  + Track type: subtitles
(MKVInfo) |  + Lacing flag: 0
(MKVInfo) |  + Codec ID: S_TEXT/UTF8
(MKVInfo) |  + Language: rum
(MKVInfo) |  + Name: Romanian
(MKVInfo) | + A track
(MKVInfo) |  + Track number: 4
(MKVInfo) |  + Track UID: 1222167943
(MKVInfo) |  + Track type: subtitles
(MKVInfo) |  + Default flag: 0
(MKVInfo) |  + Lacing flag: 0
(MKVInfo) |  + Codec ID: S_TEXT/UTF8
(MKVInfo) |  + Name: English
(MKVInfo) |+ EbmlVoid (size: 1185)
(MKVInfo) |+ Cluster


#9

It has Header Compression.   Check the FAQ.


#10

So help me how can I remove Header Compression


#11

amro_

You will have to roll up your sleeves a little to “fix” your MKV. I hear WD will soon release a firmware fix for the WDTV Live. But until then, this guide should provide you all the tools and info you need:

http://wdtvforum.com/main/index.php?topic=6897.0

I have used this method myself -it works well.

Cheers,

BR


#12

As Tony said, you can read the FAQ.

But basically you need to either run it through MKVMerge 4.0 or earlier (the “good” version) or take a later version of MKVMerge and turn off video and audio headers.


#13

As I said before follow all the instructions on the link I gave you. Look at the picture and turn off the compression on video and audio.

http://community.wdc.com/t5/General-Discussions/WDTV-Live-not-play-MKV-or-video-file-at-all-solution/m-p/53304/highlight/true#M12791