PlexPy for PR2100/4100

Hopefully there will also PlexPy in app centre for PR2100/4100 so that we can see how many times there was a login on plex and also what are the most watched movies

13 Likes

Status: Acknowledged

The WD Community can now vote on your Idea.

1 Like

Not sure how to vote but if its just a simple response here I vote yes

1 Like

Supportive/approval comments (Like yours) and “likes” received by the opening post (Clicks in the heart icon) are counted as votes.

2 Likes

Absolutely!! PlexPy NEEDS to be added to the App Center for the PR4100/2100 NAS. In my opinion it is a MUST HAVE companion app for Plex!

PLEASE add PlexPy to the App Center!

1 Like

Found this.
https://www.reddit.com/r/PleX/comments/42elt6/thought_id_share_this_with_the_community_plexpy/?st=ixj0s4e1&sh=ba66d627

As I deem waiting for WD to actually implement something a pointless exercise, I am going to try and install it via docker.

You need SSH access to your nas and some basic linux knowledge.

I will post outcome here in few days.

1 Like

There, done.
Requirements:

  • Basic linux knowledge, basic caution
  • Create directory where config data for plexpy will be stored. Anywhere is fine, just note down full path in linux format to this directory.
  • You need to create user with uid 1000 and provide RW access for this user to config directory and RO access to plex logs directory. If uid 1000 is already taken, change accordingly and modify the puid parameter for docker. Please do not ask me how to do this, its fairly easy, google is your friend. Hint - adduser + chmod + chown
  • alternatively, you can run it under admin account, uid 500, at your own risk

How to do it:
SSH to your device.

Enter following commands:

docker pull linuxserver/plexpy

docker create --name=plexpy -v (your directory for config data, create one first):/config -v “/mnt/HD/HD_a2/Nas_Prog/plex_conf/Plex Media Server/Logs”:/logs:ro -e PUID=1000 -p 8186:8181 linuxserver/plexpy

docker start plexpy

Now point your browser to ip_of_your_nas:8186

Go through web config.

Container will be stopped after device restart, you just need to run it through docker start plexpy after device restart, update or power loss. I know there is a way to make container restart automatically, but I am just too lazy to look into this right now…

EDIT
Automatic restart:
Instead of starting plexpy container with docker start plexpy, use

docker run --restart=always plexpy

Not tested, but should work.

I ended up just installing PlexPy onto a cloud server I have control of and pointing it to my Plex public IP; seems to work fine, and solves my issue.

Awesome - thanks Corwin!!!

…now I just need to figure out how to install Sonarr on my PR2100 and I’ll be sorted (not very linux literate!)

It should be fairly similar. Package you are looking for is linuxserver/sonarr

https://hub.docker.com/r/linuxserver/sonarr/

This is just a theory not tested but it should work:

ssh to your device

docker pull linuxserver/sonarr

Below is a skeleton of create command, replace values in () with values valid for your system

docker create --name=sonarr -p 8989:(port) -e PUID=(UID) -v /dev/rtc:/dev/rtc:ro -v (/path/to/appdata):/config -v (path/to/tvseries):/tv -v (path/to/downloadclient-downloads):/downloads linuxserver/sonarr

Few comments>
Port - I guess self explanatory
UID - refer to plexpy explanation, same applies here
/path/to/appdata - directory you have created to store config for sonarr permanently
path/to/tvseries - directory where you store your series
path/to/downloadclient-downloads - your download directory
There should be no () in the create command you use
Remeber to put any path containing spaces into “”

And when done, finish with:

docker run --restart=always sonarr

Let me know if it works for you.

EDIT 17/02/2017 - fixed the create command as per CIARAN_DUFFY post

Thanks Corwin - almost perfect - just one minor change to the command by adding linuxserver/sonarr to the end.:

docker create --name=sonarr -p 8989:8989 -e PUID=1006 -e PGID=1001 -v /dev/rtc:/dev/rtc:ro -v /shares/Sonarr/config:/config -v /shares/Public/SharedVideos/TVShows:/tv -v /shares/Public/Download:/downloads linuxserver/sonarr

Have Sonarr up and running now but the only problem I have is that Sonarr doesn’t seem to be able to access by Downloads folder (where Transmission saves the files) in order to rename and move - really frustrating.

Fairly sure it’s a Permissions issue but I’ve recursively chown/chmod the files/folders to match the UID (usersonarr) above but it still won’t work.

Transmission does seem to be saving all downloaded files under root:root permissions too (another issue) but is there any way for me to change the user who’s running Sonarr in order to test access?

Is it possible ssh into Busybox with an account other than root?

Hello CIARAN_DUFFY,
oops, sorry, I will edit my post and fix the command.
Regarding the permissions issue… What about approaching it from the other side?
Instead of trying to fix transmission permissions, what about running it in another container (disable the one from WD) under same user (PUID) as sonarr?
I have no means to test this, as I have just moved and my home network is next to nonexistent, but try:

docker search transmission

and pick the most used package, then google the manpages / wiki for it. Once you got the knack for it, which you have, you should be able to set up in no time. It should be only 2 parameters -v (config and download folder) and one -p (port)…

I am fairly sure it should fix the issue.
EDIT:
Actually it should be 2x -p (port), one for port forwarding needed for active connections and second for web interface. Short between my headset, sorry…

Very useful, thanks.

This is a very useful thread.
I am trying to run plexpy as a docker container, however i have the EX4100 device.

Following the instructions of @corwin_x i get the following error:
Error response from daemon: Cannot start container plexpy: [8] System error: exec format error
Error: failed to start containers: [plexpy]

Any idea why it wouldn’t work on the EX4100 compared to the PR4100 ?

Thanks alot

Hello,

I have checked, and it seems that the issue is that the EX series have ARM based processor (Marvell Armada), while PR have x86.
As far as I know the docker images are not cross-platform compliant. Well, not per se, but binaries included. So you will need to find package for ARM based devices. Other than that, the process should be the same.

Has anyone figured out a full install on a PR4100? I would like to be able to see info on my Plex Server? I would think that by now someone has made an actual app to run on the system?

Bit late to the party, but PlexPy / Tautulli is available for the whole WD My Cloud range at https://www.wdcommunity.com.
See here for more info.

Thanks!! Been wanting to install this.!!

I installed it on the PR4100, I did install Tautulli first, then uninstalled it, and installed the entware, then the Tautulli again, it did not let me configure, so I uninstalled them both and rebooted. But when I rebooted the entware was still installed. I then installed the Tautulli again. Then tried to configure with no luck. Any idea?

Okay, you’ve done most of the recommended steps already.
Could you open SSH and provide me some info

cdnp && cd tautulli/Tautulli-master
which python
python --version
python PlexPy.py --port 8282                  # type CTRL-C to close it again