Plex setup - EX2100 Unable to connect

I installed the Plex Media Server app on my EX2100.  When I hit configure it opened the Plex app site & I was able to add my movie library. Once it finished scanning almost instantly I got a “cannot find server” warning on the Plex page. I deleted the app & reinstalled it & now mid-scan it lost connection.  I then decided to install the latest updated version manually.  Then when I hit “configure” I no longer can even get to Plex. “Unable to connect. Firefox can’t establish a connection to the server at X.X.X.X:32400”. So I deleted that app & reinstalled the original app figuring at least I could get it to connect to Plex but it no longer can either.  When I hit configure, same message “Unable to connect. Firefox can’t establish a connection to the server at X.X.X.X:32400”

So I’m lost what to do.  My EX2100 is connected via ethernet to my Airport extreme router.  Is it a Plex Media Server issue? How come the initial setup I was able to go through every step in setting it up after configure but now it won’t even connect?

Hello there and welcome to the WD community.

Have you tried resetting the unit to see if this helps fix this issue ? Lets see if another user can help you out with information and tips on this matter. 

Thanks for the reply.  I tried that and many other things and nothing worked.  After searching around I found some others with the same problem on the Plex forum.  This had the solution --> https://forums.plex.tv/discussion/172859/unable-to-access-web-interface-after-settings-change-solved

What I had to do is ssh into the Ex2100 & delete the Preferences.xml file and the database file was corrupt so I deleted that as well.  Once I did that I reinstalled the Plex app, hit ‘configure’ and it connected to the Plex server.  Note: I had to enlist my friend who is a computer tech guy to help me as I really had no idea what commands to use to get to the .xml & database file.

I have the same problem on my new EX4100.

Its problem for me, because PLEX was a one of reasons to buy this NAS…

The link provided goes to a post that has been deleted and does not offer any type of fix.

I am having the same problem. I have nothing on my EX2100 except movies and the Plex application.

If I restart the nas and then open plex on my computer I can see it. But the moment I try to update library or force refresh the nas disconnects and cannot be seen. 

I have done the update, i have reinstalled Plex. At this point I am considering formating the drives and starting over. My hesitation is that it took 9 hours to load the movies on there and I didnt want to sit thru that again

The other thing to mention is that I have a MyBook Live that I had all the movies on before and it had no issues with connections. I have removed it and am using the default port  that was working with the other drive but this is still happening.

I doubt that formatting the drives will fix your issue.  Too many people re-format drives only to find that did not solve things.  So, two suggestions.  Be sure you have downloaded the complete user guide for your NAS and have referred to it.  Secondly, call WD support for some assist.

Could you please post instructions on how to SSH into the NAS and delete that file? Having the same issues here. Thanks

Yeah, call your computer tech guy friend like I did. :wink:
Seriously though, you can Google how to SSH into the server, I’m on a Mac so I used Terminal. Once I was “inside” the server I had no idea what to do. I see my original link went down after I posted it. I found this on the Plex forums that may be of some use to you if you read through them.

I also couldn’t establish a connection to the server at X.X.X.X:32400.

I found this error in the Plex Media Server log file tail -f /mnt/HD/HD_a2/plex_conf/Plex\ Media\ Server/Logs/Plex\ Media\ Server.log:

Jan 28, 2017 22:57:35.481 [0xb585f150] DEBUG - Listening on port 32400 with queue of 128 connections.
Jan 28, 2017 22:57:35.488 [0xb585f150] ERROR - Error: Unable to set up server: bind: Cannot assign requested address

I had to connect via SSH to edit the with the vi editor.
vi /mnt/HD/HD_a2/plex_conf/Plex\ Media\ Server/Preferences.xml
I changed EnableIPv6="1" to EnableIPv6="0".
Afterwards it works again.

Here is a fix that worked for me and is related to the fix for Micha1. Thanks to Micha1’s idea I checked the IPv6 settings on my PR2100.

  1. Settings --> Network --> IPv6 Network Mode
    It was “Off” and I changed it to “DHCP”. It asked for extra settings but I left them blank.
  2. restart Plex.

Then I was able to access Plex at https://X.X.X.X:32400/web/index.html