Plex on MyCloud Home: 1. Artwork (music, series, movies) not loading + 2. Unable to disable/configure

Hi all

First post on this forum -

I’ve got a bit a of a problem with my Plex Server running on my 3TB WD MyCloud Home. As of a few days ago, Plex stopped downloading images for all new music albums (on some, only adding artist images). Then, a few days later, it started doing the same for shows, and as of this morning, for movies as well.

I’ve been going over numerous forum posts, tried refreshing metadata several times, rebooting the MyCloud, etc… no luck. I then read somewhere a solution might be to Disable Plex through the MyCloud home page… tried doing that, and now it’s just unresponsive - I can’t “configure” or “disable”, and just get a message “Service Not Available” … despite the Server still showing up in my mobile app, and when I Launch through

Any tips on what I should do? At this point I’m guessing my best bet is to uninstall Plex, and re-install, but I can’t figure out how to do that on the MyCloud Home… Help?

Thanks in advance!

They’re can only be one library updating at a time
Did anything change in Settings > Server > Library ?