Please Help!


#1

I just bought a 500 GB / 1TB WD Elements External Hard Drive and I was attempting to use a Mac computer. I have a Macbook Tiger. When I connect the drive I get an alert message saying " The disc inserted was not readable by this computer". I could still click on the initialize window and it took me to the disk utility window. There I tried to format the disc  and I get a message saying " Partition failed with the error:  Input / output error". So that’s the error message I am getting and I don;t know how to solve this or what the problem is.

I have tried this over and over and checked cables, etc. and whenever I try to do something on the drive, the same error pops up.

The drive icon does not show up in my desktop but on the disk utility window it reads it and all the info comes out there; It’s size, model, etc.

I tried it on a 3 month old Macbook Pro as well and the same exact problem occured.

Can someone help me out with this please? How do I fix this?

Thanks in advance.


#2

FYI: The Elements External Hard Drive was formatted for PC but, you can format it with Mac file system to use with Mac computer.

Here is how to format it under Mac computer using the disk utilities:

Please click on this link to study on how to format it, It will shown windows by default,

You need to click on Mac OS link to see the Mac instruction. 

http://wdc.custhelp.com/cgi-bin/wdc.cfg/php/enduser/std_adp.php?p_faqid=3865&p_created=1258601352&p_sid=gK3EcMXj&p_accessibility=0&p_redirect=&p_srch=1&p_lva=&p_sp=cF9zcmNoPTEmcF9zb3J0X2J5PSZwX2dyaWRzb3J0PSZwX3Jvd19jbnQ9NjIsNjImcF9wcm9kcz0yMjgsMjYwLDMxOCZwX2NhdHM9JnBfcHY9My4zMTgmcF9jdj0mcF9wYWdlPTEmcF9zZWFyY2hfdGV4dD1wYXJ0aXRpb24gZm9yIG1hYw!!&p_li=&p_topview=1


#3

 Well thanks for taking the time to answer. But I found your answer frustrating since I stated clearly in my post that I had ALREADY tried what you said a hundred times.  If someone knows the problem and what the error messages I am getting mean, please help. I think my post was very clear and understandable…


#4

If you have tried to format it correctly by:

From the Disk Utility

Select Partition,

From a Volume Scheme, create a partition,

Under Options choose Apple files system (GUID, Apple Partition Map)

Then get the error you mentioned.

Try the Verify Disk to see if it can find anything wrong with the drive.

If yes, do the Repair Disk.

If nothing is improve, try the next suggestion below. 

Another suggestion:

Try to format it on a PC windows machine.

If the problem is still the same

Then the drive is defective.

You need to contact WD tech support to get your drive replace.

www.wdc.com/support


#5

hi,

try it on Windows Machine format it with NTFS. it may firmware got problem if still no help.


#6

I still didn’t find  a solution, so went to my local dealer and since I still had warranty I am getting a new one replaced.

Thanks for help


#7

hi,

yeah. you should RMA if still under warranty. have nice day.