Please Help. WD My Pasport Ultra No Longer Accessible on my MacBook Pro

Hi there,

I’ve had a My Passport Ultra for about 3 months and have used it daily with my MacBook Pro. I plugged it in today, and the device is no longer showing up on my computer. I tried it on my other mac computer (which it also works on) and no dice either. If I go into the utilties in applications, I can see it listed. I’ve tried doing the repair but it says it cannot do this and to back up my files and restore the hard drive. I phoned WD support and was told I can only try a different cable, otherwise my files are gone. I’m wondering if anyone can confirm if this sounds like a cable issue, considering when I plug it into the computer the light on it flashes for a bit, and I can see the name of it it listed in the Utilities (but I can’t seem to access it).

Appreciate any help. I have a lot of important work files and I purchased this item for this very reason.

Thank you


There are several different factors that could result in the current situation. Is your WD Passport Ultra accessible on a different computer? Is the disk drive detected on a Microsoft Windows system? Replacing the cable may produce positive results if changed to a Micro USB 2.0 cable from an Android device. The Micro USB 3.0 connector on your WD Passport Ultra may look complex, but it was designed to allow Micro USB 2.0 cables to be connected in order to enforce USB 2.0 mode in case there is a compatibility issue with the USB 3.0 driver on the host system.