PLEASE HELP My Book Home Edition Problem with firmware and other problems


#1

I will try to keep this as short as possible.

  1. I am trying to update my firmware and i am running windows 7 64 but ervery time i run it the following error occurs “ERROR WHILE LOADING GENERIC LIBRARY”.

  2. I have a router/modem (Belkin N+) with a USB port which i can attach this drive and can pick it up on my network, this works fine for 10mins then the drive decides to go to sleep and will not wake up. I then have to unplug and mess around to get it to show up on my PC again.

I would be really happy if someone can help me as i dont want to let this beat me.


#2

I’m having the same problem, same OS.

I have a feeling it has to do with us running 64 bit.  I tried different compatability modes to no avail.

Then again, I could be wrong, I just connected it to an 32bit XP system and recieved a could not write to boot sector error.  I may have a hardware issue.

I’ll post again if I find a solution.


#3

I have emailed tech support so i will let you know what the reply is, dont hold your breath though as the last reply i had was as if it was from a ROBOT.


#4

I tried another computer and couldn’t get it to work. 

I just did an RMA because there seem to be more issues besides just this one.

Hopefully the next drive will not have any issues.

Let me know what tech responds with anyways.

Thanks!


#5

Well I did phone them as I have still had no reply to my request for assistance from the website.  The chap was quite helpful and told me he would email a firmware update because the one he had works.  What do you know - it never showed and now its 2 days later.  I tried to call again yesterday but CLOSED.

Although they are very polite the whole service it totally useless.

I am wondering how I would go about getting a replacement, if it wont load firmware updates is it classed as faulty.


#6

This has been noted and has been passed along to our European support group. 


#7

well, if you are having hardware issues, such as what you described in the original post, and you also can’t load firmware that the MFR has made specifically for the drive, then I’d say you have reason to believe the drive is faulty.  But at the same time, there could be some obscure setting somewhere that you can magically change that will make everything better.  Hopefully the chaps in european tech support will be able to fix it. 

Otherwise I’m sure they’ll change it out for you.

The only thing that ■■■■■ about getting a warranty replacement is they always send out a recertified drive. 

I got my replacement already and it works like a champ.

Good luck. 


#8

As I stated in another thread, there appears to be issues with updating the firmware on these external drives.  A lot of people are reporting problems, and I think WD needs to take a closer look at their updater.


#9

I am running Windows 7/64 bit also and just finished installing and running MyBook Elite for the first time without any problems and this is my first experience ever with an external hard drive. The only thing I did that I don’t see mentioned in the other posts here is that I followed the warning to disable any AV software before installing an upgrading the firm ware.